Security/Turn signal issues - Harley Davidson Forums: Harley Davidson Motorcycle Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 12-28-2009, 04:45 PM Thread Starter
Junior Member
 
Join Date: Dec 2009
Location: Bear, DE
Posts: 5
Security/Turn signal issues

I have a 2002 FLHT with security system. When the ignition is put in the "on" position, both turn signals flash several times, and the security light stays on. I can put on the four way flashers on, and the security light will stay off until I activate the left turn signal. No problem with the right signal. Occasionally the left signals will blink real fast.

This happened once before, last summer, but went away on its own. I should note that I have a Kuryakin LED tail light and turn signals. The LED's have been on the bike for several years without incident. I took off the seat and bypassed the LED harness, but there is no change. Any thoughts? Thanks!!
johnmc906 is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 12-29-2009, 05:35 AM
Retired citizen
 
SCHMIDTYS's Avatar
 
Join Date: Jun 2009
Location: Pt. Wash.,WI
Posts: 14,683
Water in the light housings or the controller / ballast is going bad .
Check in at the New to the Community section while you're at it and ya might get some more feed back .

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTYS is online now  
post #3 of 12 (permalink) Old 12-29-2009, 04:01 PM
PRO BIKE FLIPPER
 
serviceguy85's Avatar
 
Join Date: Nov 2009
Location: YOUR LOCAL HD DEALER
Posts: 1,351
tssm might be having problems, no way of testing that without putting another one in, and go introduce yourself ha

""IF MY HARLEY WAS MEANT TO BE "MY BABY" I WOULD OF BEEN IN JAIL A WHILE AGO FOR HOW BADLY I BEAT IT...."

04 FLHP- PROJECT GOT WOOD... COMING SPRING.

"You never see a herse with a luggage rack..."

Last edited by serviceguy85; 12-30-2009 at 08:36 AM.
serviceguy85 is offline  
post #4 of 12 (permalink) Old 12-30-2009, 06:19 AM
Retired citizen
 
SCHMIDTYS's Avatar
 
Join Date: Jun 2009
Location: Pt. Wash.,WI
Posts: 14,683
Quote:
Originally Posted by serviceguy85 View Post
tssm might be having problems, now way of teating that without putting another one in, and go introduce yourself ha
YES ... if the turn signals all flash several times after turning on the ignition the ECM has a stored code for the TSSM system . Use the trip meter button to read the codes . There's a " sticky " here that explains the procedure .

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTYS is online now  
post #5 of 12 (permalink) Old 12-30-2009, 08:38 AM
PRO BIKE FLIPPER
 
serviceguy85's Avatar
 
Join Date: Nov 2009
Location: YOUR LOCAL HD DEALER
Posts: 1,351
Quote:
Originally Posted by SCHMIDTYS View Post
YES ... if the turn signals all flash several times after turning on the ignition the ECM has a stored code for the TSSM system . Use the trip meter button to read the codes . There's a " sticky " here that explains the procedure .
yup yup, btw thanks for quoting me, i looked at it and my spelling was horrible ha

""IF MY HARLEY WAS MEANT TO BE "MY BABY" I WOULD OF BEEN IN JAIL A WHILE AGO FOR HOW BADLY I BEAT IT...."

04 FLHP- PROJECT GOT WOOD... COMING SPRING.

"You never see a herse with a luggage rack..."
serviceguy85 is offline  
post #6 of 12 (permalink) Old 01-04-2010, 10:11 AM Thread Starter
Junior Member
 
Join Date: Dec 2009
Location: Bear, DE
Posts: 5
Thanks, guys, will look into it!
johnmc906 is offline  
post #7 of 12 (permalink) Old 01-05-2010, 12:00 PM Thread Starter
Junior Member
 
Join Date: Dec 2009
Location: Bear, DE
Posts: 5
Quote:
Originally Posted by johnmc906 View Post
I have a 2002 FLHT with security system. When the ignition is put in the "on" position, both turn signals flash several times, and the security light stays on. I can put on the four way flashers on, and the security light will stay off until I activate the left turn signal. No problem with the right signal. Occasionally the left signals will blink real fast.

This happened once before, last summer, but went away on its own. I should note that I have a Kuryakin LED tail light and turn signals. The LED's have been on the bike for several years without incident. I took off the seat and bypassed the LED harness, but there is no change. Any thoughts? Thanks!!
I got the diagnostic codes, it is showing the left and right turn signals have a problem, and a side note says this could also be a failure of the TS/SM module. Since I don't have one of those laying around, I think I will let the dealer play with it. I am going to be using Barb's H/D in Collingswood, NJ for the first time. Does anyone have any experience with them? Or another dealer in that area? Previous services and repairs were done in either North Jersey of Florida. Thanks again for your assistance to those who answered me.
johnmc906 is offline  
post #8 of 12 (permalink) Old 01-06-2010, 05:40 AM
Retired citizen
 
SCHMIDTYS's Avatar
 
Join Date: Jun 2009
Location: Pt. Wash.,WI
Posts: 14,683
Quote:
Originally Posted by johnmc906 View Post
I got the diagnostic codes, it is showing the left and right turn signals have a problem, and a side note says this could also be a failure of the TS/SM module. Since I don't have one of those laying around, I think I will let the dealer play with it. I am going to be using Barb's H/D in Collingswood, NJ for the first time. Does anyone have any experience with them? Or another dealer in that area? Previous services and repairs were done in either North Jersey of Florida. Thanks again for your assistance to those who answered me.
What are the code numbers that came up ???

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTYS is online now  
post #9 of 12 (permalink) Old 01-06-2010, 08:31 AM Thread Starter
Junior Member
 
Join Date: Dec 2009
Location: Bear, DE
Posts: 5
Codes were 21 and 22. I do not have the the sheet handy to say exactly what they are.
johnmc906 is offline  
post #10 of 12 (permalink) Old 01-06-2010, 09:17 AM
Retired citizen
 
SCHMIDTYS's Avatar
 
Join Date: Jun 2009
Location: Pt. Wash.,WI
Posts: 14,683
Quote:
Originally Posted by johnmc906 View Post
Codes were 21 and 22. I do not have the the sheet handy to say exactly what they are.
Should be a B , P or U followed by 4 numbers . :mwink

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTYS is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome