Check Engine Light - Harley Davidson Forums: Harley Davidson Motorcycle Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 35 (permalink) Old 04-30-2010, 11:44 AM Thread Starter
Member
 
slw0102's Avatar
 
Join Date: Jan 2010
Location: Columbus, OH
Posts: 60
Check Engine Light

Hello all, Hope I can draw upon some experiences with this, but my check engine light will come on after I start my bike, then go out after about 5 seconds. It will not come on again at all until I shut off the bike and restart, then again, it will go off then come on for 5 seconds then go off again. I do not have any trouble codes and am wondering if this is something I should be concerned about at all. The bike's performance does not seem to be effected at all.
Any thoughts would be appreciated
06 FXDLI
Thanks
slw0102 is offline  
Sponsored Links
Advertisement
 
post #2 of 35 (permalink) Old 04-30-2010, 01:12 PM
Luke 22:36
 
Kainam's Avatar
 
Join Date: Oct 2006
Location: Kansas City
Posts: 19,914
Images: 149
Garage
Are you letting the fuel pump build pressure before you start your bike, or do you just turn the key on and hit the starter button right away?

'05 Carbed Night Train
111 rwhp, 112 rwtq
Best 1/4 ET 12.557s
Best 1/4 MPH 108.59
Kainam is online now  
post #3 of 35 (permalink) Old 04-30-2010, 01:58 PM
Curmudgeon
 
scol's Avatar
 
Join Date: Oct 2008
Location: ...............
Posts: 6,492
Images: 74
I just went out to my 2008 sporty and started it right away, engine light didn't come on, but I've been running it today as of 45min. ago. So I got nothing. Did you check owners manual?

Never kick a fresh turd on a hot day.
― Harry S. Truman

They who can give up essential liberty to obtain a little temporary safety, deserve neither liberty nor safety
Benjamin Franklin

"An appeaser is one who feeds a crocodile, hoping it will eat him last.
Winston Churchill
scol is offline  
post #4 of 35 (permalink) Old 04-30-2010, 02:43 PM
2010 Heritage
 
Rossco's Avatar
 
Join Date: Feb 2010
Location: Montreal
Posts: 1,198
Images: 5
Just checked mine. The check engine light comes on when I turn the kill switch to "run". It stays on while the fuel pump pressurizes the line (maybe 3 seconds), then goes off about a second after the pump stops running. On for a total of about 4 seconds (5 tops). I don't know if your bike has FI, but if it does you are supposed to wait for the fuel line to be pressurized before starting.
Rossco is offline  
post #5 of 35 (permalink) Old 04-30-2010, 02:46 PM
Luke 22:36
 
Kainam's Avatar
 
Join Date: Oct 2006
Location: Kansas City
Posts: 19,914
Images: 149
Garage
Yup he has a FXDLI according to his post.

'05 Carbed Night Train
111 rwhp, 112 rwtq
Best 1/4 ET 12.557s
Best 1/4 MPH 108.59
Kainam is online now  
post #6 of 35 (permalink) Old 04-30-2010, 02:52 PM
2010 Heritage
 
Rossco's Avatar
 
Join Date: Feb 2010
Location: Montreal
Posts: 1,198
Images: 5
Quote:
Originally Posted by Kainam View Post
Yup he has a FXDLI according to his post.
Ah yes. Sorry, I am still learning the Harley nomenclature.
Rossco is offline  
post #7 of 35 (permalink) Old 04-30-2010, 03:26 PM Thread Starter
Member
 
slw0102's Avatar
 
Join Date: Jan 2010
Location: Columbus, OH
Posts: 60
A couple of replies asked if I am waiting for the line to pressurize and the answer is definitely yes I am. Again, seems strange, but it comes on when I hit the run button, I wait until the fuel line is pressurized, then I hit start. When the bike starts the light will go off then about 2 seconds later back on for approx 5 seconds then go out again.
I appreciate feedback from everyone
Thanks
slw0102 is offline  
post #8 of 35 (permalink) Old 04-30-2010, 03:33 PM
2010 Heritage
 
Rossco's Avatar
 
Join Date: Feb 2010
Location: Montreal
Posts: 1,198
Images: 5
That going back on thing is weird. Have you bounced this off of your dealer's service dept? At least it doesn't stay on.


Just a thought. Sometimes these lights are programmed to come on to indicate that you have reached the mileage for a scheduled maintenance. Is this a possibility?
Rossco is offline  
post #9 of 35 (permalink) Old 04-30-2010, 03:35 PM
MPG'S? Who gives a
 
Craiger's Avatar
 
Join Date: Jul 2008
Location: Mostly @ work
Posts: 9,909
Images: 11
Garage
The obvious was ckecked right ??...oil level ??loose batt. cables or wire connections ?

08 FLHTC. Breathing well and getting lots to drink.
Craiger is offline  
post #10 of 35 (permalink) Old 04-30-2010, 03:36 PM Thread Starter
Member
 
slw0102's Avatar
 
Join Date: Jan 2010
Location: Columbus, OH
Posts: 60
Your right it is weird. Just for kicks I tried something a little different. This only occurs when I first turn the key on. If I run the bike and use the kill switch and do not turn the key off, I can restart with no light.
slw0102 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome