speakers crackling cutting in and out - Harley Davidson Forums: Harley Davidson Motorcycle Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 (permalink) Old 06-15-2008, 11:03 PM Thread Starter
Bumblebee
 
bulldog4949's Avatar
 
Join Date: Jun 2008
Location: Texas Panhandle
Posts: 10
speakers crackling cutting in and out

My front right and back left speakers are crackling, and cutting on and off. When I hit a bump, or dip...it seems to come back on for a few minutes. I have had the fairing off before, and just want to know if anyone else has had any luck checking a ground wire or a pliug in area? Thanks!!

2008 HD Ultra Classic
103 cu motor
SE 211 cams
bulldog4949 is offline  
Sponsored Links
Advertisement
 
post #2 of 11 (permalink) Old 06-19-2008, 08:36 PM Thread Starter
Bumblebee
 
bulldog4949's Avatar
 
Join Date: Jun 2008
Location: Texas Panhandle
Posts: 10
Got it fixed!!! Nevermind!!!

2008 HD Ultra Classic
103 cu motor
SE 211 cams
bulldog4949 is offline  
post #3 of 11 (permalink) Old 06-24-2009, 12:45 AM
Junior Member
 
Join Date: Jun 2009
Location: wisconsin
Posts: 2
hello I see you answered your own question what did you find ?
harley89 is offline  
post #4 of 11 (permalink) Old 08-04-2012, 01:50 PM
Hard Member
 
Rum Runner's Avatar
 
Join Date: Aug 2012
Location: Fredericksburg, VA
Posts: 1,671
Sound issue

Quote:
Originally Posted by bulldog4949 View Post
Got it fixed!!! Nevermind!!!
I have the same issue with my 07 ultra, as I am riding, the sound goes out, so I flip the 3 way switch close to the ignition block. However, it keeps going out. I ran a diagnostic on the radio and it gave me two codes. B2017 (LF speaker) and B2021 (RR speaker), both indicate open. Do you know what I should do to fix this issue?
Rum Runner is online now  
post #5 of 11 (permalink) Old 08-04-2012, 02:26 PM
I'll help you hide the body
 
misinlink's Avatar
 
Join Date: Mar 2011
Location: S Florida
Posts: 6,795
check for loose or damaged wires....

Leave the gun. Take the cannoli.



borrowed from gtrman66
Rules:
#1. Post #1: "New to Community"
#2. Buy a HD Service Manual, best $70 you'll spend
#3. Try the search function, we might have already answered your question
#4. Don't post classifieds until you meet the rules
#5. Don't bad mouth dealers until we know you, there are always 2 sides
misinlink is online now  
post #6 of 11 (permalink) Old 08-29-2012, 02:56 PM
Hard Member
 
Rum Runner's Avatar
 
Join Date: Aug 2012
Location: Fredericksburg, VA
Posts: 1,671
Speakers cutting off

Well, figuring that HD would run me a good size bill, I did the next thing that comes to mind and installed my own system! After research, I ordered a system from Biketronics. Prior to installation: RT handlebar stereo controls not working, LT control partially working, 3 way switch by ignition replaced, however sound kept cutting off. After installation, both handlebar controls are working, switch by ignition not needed, intercom and cb no longer works. What I purchased: Sony DSX-S100 (IPOD/USB) tray, Biketronics BT1002 installation kit, BT480 amplifier kit (180 RMS), BT471 Titan II 6 1/2" speakers with mounts, Retroradio module (Biketronics innovation). Mike the owner also threw 4 USB thumbs (funny, bottle opener at the end) and a splash cover for the radio face. Speakers, amp, retroradio have lifetime warranty. Believe me, the sounds are really clear, I also added a pair of Polk DXI525 5 1/4" on tour pak pods, no amp needed, this setup sounds like a car stereo, and it does turn heads! Well worth the $1,045.00 I spent (HD will replace under warranty with a refurbished radio, not a new one which costs $1,000.
Rum Runner is online now  
post #7 of 11 (permalink) Old 10-07-2012, 05:59 AM
Junior Member
 
Join Date: Oct 2012
Location: Erie pa
Posts: 3
Problem with my radio was when riding, speakers would randomly just cut out. If I shut radio off and turn back on, it would work fine. I removed the fairing and speaker wires were barely connected. I made better connection but now I have absolutely no sound. Radio looks like it works fine but have no music. I've checked for pinched wires but can't find anything. Help would be much appreciated.


Sent from my iPhone using MO Free
Mpkleiner is offline  
post #8 of 11 (permalink) Old 11-11-2012, 12:10 PM
Junior Member
 
Join Date: Oct 2012
Location: Erie pa
Posts: 3
Seriously? Nobody on here can answer?


Sent from my iPhone using Motorcycle.com Free App
Mpkleiner is offline  
post #9 of 11 (permalink) Old 11-11-2012, 05:14 PM
UnreconstructedRebel
 
webco2's Avatar
 
Join Date: Jul 2012
Location: Texas
Posts: 7,840
Check your ground first off.....
webco2 is online now  
post #10 of 11 (permalink) Old 11-12-2012, 04:06 AM
Junior Member
 
Join Date: Apr 2012
Location: nj
Posts: 26
Quote:
Originally Posted by Mpkleiner View Post
Seriously? Nobody on here can answer?


Sent from my iPhone using Motorcycle.com Free App

Give Iron Cross Audio a call...they should be able to guide you.
tech is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome