Tsm Problem - Harley Davidson Forums: Harley Davidson Motorcycle Forum
Harley-DavidsonForums.com is an independent enthusiast website owned and operated by VerticalScope Inc. Harley-DavidsonForums.com is not sponsored by or in any way affiliated with Harley-Davidson Inc.. The Harley Davidson names and logos are trademarks owned by Harley-Davidson Inc.

Go Back   Harley Davidson Forums: Harley Davidson Motorcycle Forum > Technical > Electrical

» Insurance
» Our Partners
»ATV Reviews
»Motorcycle Games
Reply
 
LinkBack Thread Tools Display Modes
Old 01-12-2012, 03:22 PM   #1 (permalink)
Junior Member
 
Join Date: Dec 2011
Location: ma
Posts: 2
Tsm Problem

I am new here and hope someone can give a little help, please.
I just bought my first Harley, a 1999 road king. I took off the tins had them painted and put it all back together. Now the left turn signal and hazards do not work and I am not really sure if it worked before.
I did trouble shoot the system and everything seems fine. the right turn signal works when you hit the right turn button but the left does not and the hazards don't work. I traced the wires no shorts and all the grounds are good. I have power going to the tsm, the left switch sends a signal to the tsm when depressed but nothing happens. The left directionals light up when fed power so I know they are ok. even changed all the bulbs just incase. the ground for the tsm is also good. I went ahead and ordered a new one from the dealer but I am not sure if I need one.
Is there a way to test the tsm? I check my manual but all it states is to refer to a harley dealer if it passes all the checks that it states to do.
Would having the battery disconnected for a long time have anything to do with this? Is there something I should have done when I hooked up the battery back? Could I have caused this issue in some way?
any help would be appreciated.
thanks
mo249 is offline   Reply With Quote
Old 01-12-2012, 05:26 PM   #2 (permalink)
Bikeless....for now!
 
RDK09's Avatar
 
Join Date: Sep 2009
Location: PA
Posts: 5,112
New to the Community - Harley Davidson Forums: Harley Davidson Motorcycle Forum
__________________
"09" Road King
"10" Forty-Eight
RDK09 is offline   Reply With Quote
Old 01-16-2012, 12:04 PM   #3 (permalink)
Junior Member
 
Join Date: Dec 2011
Location: ma
Posts: 2
never mind got all the help I need from another forum
mo249 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 02:51 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
This site is in no way affiliated with Harley-Davidson
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum