Radio Problems - Harley Davidson Forums: Harley Davidson Motorcycle Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 25 (permalink) Old 03-13-2012, 06:53 PM Thread Starter
Senior Member
 
Join Date: May 2011
Location: Illinois
Posts: 226
Unhappy Radio Problems

I have a '07 Harley radio that i am not able to hear any sound through the speakers. When i turn on the radio, the screen comes on, volume control shows turning up and down and changing stations also but still have no sound at all. Is there something i can do or is this a "send in to get it fixed" deal? Are these radios repairable or is it time to look for another radio? Hopefully this radio can be repaired. Thanks for any of your help.
Gliderider is offline  
Sponsored Links
Advertisement
 
post #2 of 25 (permalink) Old 03-13-2012, 07:37 PM
Senior Member
 
Ardeum's Avatar
 
Join Date: Apr 2010
Location: KY
Posts: 141
Do you have a speaker switch that switches off the external speakers when using helmet intercom speakers? If so, maybe the switch is bad (or just has external speakers switched off, maybe???).

'09 Ultra Classic
Ardeum is offline  
post #3 of 25 (permalink) Old 03-13-2012, 08:33 PM
Mississippi Cajun
 
kd5cqt's Avatar
 
Join Date: Dec 2006
Location: Ocean Springs,Mississippi
Posts: 10,855
Quote:
Originally Posted by Ardeum View Post
Do you have a speaker switch that switches off the external speakers when using helmet intercom speakers? If so, maybe the switch is bad (or just has external speakers switched off, maybe???).
That'd be my first guess.

USAF Veteran, PGR Member, Retired Old Fart! 2011 Electraglide Ultra Classic
kd5cqt is online now  
post #4 of 25 (permalink) Old 03-13-2012, 08:49 PM Thread Starter
Senior Member
 
Join Date: May 2011
Location: Illinois
Posts: 226
I don't use a intercom helmet and i have the Classic, which doesn't have the speaker switch like the Ultra, located near the ignition. There isn't a speaker switch on the radio that i know of, is there?? Thank you for the feedback. My ears are open.
Gliderider is offline  
post #5 of 25 (permalink) Old 03-14-2012, 07:19 AM
Retired citizen
 
SCHMIDTYS's Avatar
 
Join Date: Jun 2009
Location: Pt. Wash.,WI
Posts: 14,669
Do the radio diagnostic program . With the ignition off hold in any two buttons while turning the ignition on at the same time , that gets you into the radio diagnostics . That procedure is in your owners manual I believe .

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTYS is offline  
post #6 of 25 (permalink) Old 03-14-2012, 07:31 AM Thread Starter
Senior Member
 
Join Date: May 2011
Location: Illinois
Posts: 226
I just did the diagnostic and it gave me a "B2017 code" and said "FL Speaker Open". What is that telling me? Open connection inside the radio??
Gliderider is offline  
post #7 of 25 (permalink) Old 03-14-2012, 07:39 AM
Retired citizen
 
SCHMIDTYS's Avatar
 
Join Date: Jun 2009
Location: Pt. Wash.,WI
Posts: 14,669
Left speaker is bad or the wire came off , FL is Front Left .

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTYS is offline  
post #8 of 25 (permalink) Old 03-14-2012, 07:41 AM
Retired citizen
 
SCHMIDTYS's Avatar
 
Join Date: Jun 2009
Location: Pt. Wash.,WI
Posts: 14,669
Try bipping on the fairing with the palm of your hand to see if ya hear anything .

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTYS is offline  
post #9 of 25 (permalink) Old 03-14-2012, 07:52 AM Thread Starter
Senior Member
 
Join Date: May 2011
Location: Illinois
Posts: 226
I have a 08 ultra and a 07 classic. The 07 classic is the one with no sound. i plugged the 07 classic radio in the 08 ultra and there is no sound. I took the good radio out of the 08 ultra and tried it in the 07 classic and the radio and speakers work. Does that mean an open in the speaker circuit inside the radio itself? Just askn, i hope not.
Gliderider is offline  
post #10 of 25 (permalink) Old 03-14-2012, 07:56 AM
Retired citizen
 
SCHMIDTYS's Avatar
 
Join Date: Jun 2009
Location: Pt. Wash.,WI
Posts: 14,669
Yup , sounds like an open speaker circuit inside the radio . Take the radio to the dealer , they'll send it in to the radio company for repairs . Comes back like brand new .

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTYS is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome