Wiring speakers on a softail deluxe - Harley Davidson Forums: Harley Davidson Motorcycle Forum
Harley-DavidsonForums.com is an independent enthusiast website owned and operated by VerticalScope Inc. Harley-DavidsonForums.com is not sponsored by or in any way affiliated with Harley-Davidson Inc.. The Harley Davidson names and logos are trademarks owned by Harley-Davidson Inc.

Go Back   Harley Davidson Forums: Harley Davidson Motorcycle Forum > Technical > Electrical

» Insurance
» Our Partners
»ATV Reviews
»Motorcycle Games
Reply
 
LinkBack Thread Tools Display Modes
Old 12-08-2012, 04:35 PM   #1 (permalink)
Junior Member
 
Join Date: Dec 2012
Location: Jacksonville, FL
Posts: 3
Wiring speakers on a softail deluxe

I have an '05 Softail Deluxe that I have wired external speakers to the battery. When I leave the positive battery terminal loose, the speakers work great but once I tighten it down, the speakers stop working. Can someone help me figure this out please?
lj5500 is offline   Reply With Quote
Old 12-08-2012, 06:33 PM   #2 (permalink)
Senior Member
 
kg5ie's Avatar
 
Join Date: Sep 2012
Location: Weatherford, TX
Posts: 106
Images: 1
You wired speakers to the battery? Why do they need voltage? Do they have amplifiers or something? I have never heard of speakers needing to go to a battery.....usually only hook up to the sound source.
__________________
Bill D.
kg5ie
2009 FLSTC
kg5ie is offline   Reply With Quote
Old 12-08-2012, 06:58 PM   #3 (permalink)
Junior Member
 
Join Date: Dec 2012
Location: Jacksonville, FL
Posts: 3
The amplifier is built into the speakers.
lj5500 is offline   Reply With Quote
Old 12-08-2012, 07:41 PM   #4 (permalink)
Senior Member
 
thefour's Avatar
 
Join Date: May 2012
Location: georgia
Posts: 603
It is possible that the ground is poor.

Trigger could be improperly connected to a switched positive source. Loose

Positive cable could have a short to ground.

Check to make sure you have constant positive and negative to amp and that the trigger is where it's suppose to be.

Good luck.
thefour is offline   Reply With Quote
Old 12-08-2012, 09:16 PM   #5 (permalink)
Senior Member
 
kg5ie's Avatar
 
Join Date: Sep 2012
Location: Weatherford, TX
Posts: 106
Images: 1
Ah! Now I understand. What is the model number on the speaker kit. I'll see if I can dig up a schematic on the net to take a look at.

I found an install video for the J&M set that may be helpful....if yours are J&M.
__________________
Bill D.
kg5ie
2009 FLSTC
kg5ie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 12:45 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
This site is in no way affiliated with Harley-Davidson
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum