Tuning 2001 ultra - Harley Davidson Forums: Harley Davidson Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 12-05-2012, 05:59 PM Thread Starter
Junior Member
 
SharpeFan84's Avatar
 
Join Date: Nov 2012
Location: Wisconsin
Posts: 21
Tuning 2001 ultra

I have a 2001 ultra that is fuel injected. I put Big Louie slip ons on and now it is running lean. What is best option to fix it? Heard horror stories about M M injection but there has to be something I can do. Looking at Cobra Fi2000 hope that works.


Sent from my iPhone using Motorcycle.com Free App
SharpeFan84 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-05-2012, 06:05 PM
Grandstanding Member
 
Dave63's Avatar
 
Join Date: Jun 2008
Location: PA
Posts: 29,803
Check your basics including intake seals. Adding just pipes shouldn't make the bike lean with a stock air filter and air cleaner canister.

__________________________________________
When the going gets weird, the weird turn professional.... ~ Hunter S. Thompson~

R.I.P. Rubberdown. 1971-2012
Dave63 is offline  
post #3 of 6 (permalink) Old 12-05-2012, 06:23 PM Thread Starter
Junior Member
 
SharpeFan84's Avatar
 
Join Date: Nov 2012
Location: Wisconsin
Posts: 21
Everything stock but slip ons. So I will check intake.


Sent from my iPhone using Motorcycle.com Free App
SharpeFan84 is offline  
post #4 of 6 (permalink) Old 12-05-2012, 07:34 PM
Senior Member
 
2010hdultra's Avatar
 
Join Date: Jan 2011
Location: Princeton WV 24739
Posts: 5,070
Try fl-xieds from nightrider.com im happy with mine. Heard alot of good feedback from others before i got mine. All i did was a/c and slipons. Hopeing everything i read it true. I know i dont get any decel popping now.
2010hdultra is offline  
post #5 of 6 (permalink) Old 12-05-2012, 08:10 PM Thread Starter
Junior Member
 
SharpeFan84's Avatar
 
Join Date: Nov 2012
Location: Wisconsin
Posts: 21
Looks like they don't go back as far as 2001.
SharpeFan84 is offline  
post #6 of 6 (permalink) Old 12-05-2012, 09:07 PM
Senior Member
 
OneLugLarry's Avatar
 
Join Date: Nov 2011
Location: Indiana
Posts: 128
Images: 3
Garage
I had problems with my 2000 ultra classic being very inconsistent when I first got it also. It had a 95" kit with se 203 cams and stock header, V&H mufflers , and a power commander. I spent hours at the local indie shop on the dyno and couldnt get it to quit being a tempramental b@#ch. I ended up getting a S&S VFI ecm and after installing it and finding the right map I was happy. I am still happy with the tunability of it and am still using it even after putting high comp pistons, ported heads, 2 into 1 header, and flora cams in it .
OneLugLarry is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome