Speedometer only goes to 25mph - Harley Davidson Forums: Harley Davidson Motorcycle Forum
Harley-DavidsonForums.com is an independent enthusiast website owned and operated by VerticalScope Inc. Harley-DavidsonForums.com is not sponsored by or in any way affiliated with Harley-Davidson Inc.. The Harley Davidson names and logos are trademarks owned by Harley-Davidson Inc.

Go Back   Harley Davidson Forums: Harley Davidson Motorcycle Forum > Technical > General Service and Repair

» Insurance
» Our Partners
»ATV Reviews
»Motorcycle Games
Reply
 
LinkBack Thread Tools Display Modes
Old 11-26-2012, 01:18 PM   #1 (permalink)
Senior Member
 
AlTheKiller's Avatar
 
Join Date: Oct 2012
Location: Texas
Posts: 428
Speedometer only goes to 25mph

This morning on the way into work I noticed the speedometer wouldn't go above 25mph. Everything lights up and it shows the trip and mileage correctly though.

Where should I start looking for the problem? Anyone have this problem before?

It's a 1999 sportster 1200 custom but the tank I think is after market with the speedo mounted into it.



Thanks for any help.
AlTheKiller is offline   Reply With Quote Quick reply to this message
Old 11-26-2012, 01:22 PM   #2 (permalink)
I'll help you hide the body
 
misinlink's Avatar
 
Join Date: Mar 2011
Location: S Florida
Posts: 5,998
Have you checked the speed sensor?
__________________
Leave the gun. Take the cannoli.



borrowed from gtrman66
Rules:
#1. Post #1: "New to Community"
#2. Buy a HD Service Manual, best $70 you'll spend
#3. Try the search function, we might have already answered your question
#4. Don't post classifieds until you meet the rules
#5. Don't bad mouth dealers until we know you, there are always 2 sides
misinlink is offline   Reply With Quote Quick reply to this message
Old 11-26-2012, 01:28 PM   #3 (permalink)
Senior Member
 
AlTheKiller's Avatar
 
Join Date: Oct 2012
Location: Texas
Posts: 428
No sir. I haven't checked a thing since I've been at work. Would that be the best place to start?
AlTheKiller is offline   Reply With Quote Quick reply to this message
Old 11-27-2012, 08:09 AM   #4 (permalink)
Retired citizen
 
SCHMIDTYS's Avatar
 
Join Date: Jun 2009
Location: Pt. Wash.,WI
Posts: 13,121
Agreed about the speed sensor. It's located behind and below the starter on top of the trans case. One wire to it and one Allen bolt holding it in. Remove the sensor and clean the debris off the magnet. The debris interferes with the speed signal.
__________________
Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTYS is offline   Reply With Quote Quick reply to this message
Old 11-27-2012, 11:05 AM   #5 (permalink)
Banned
 
Join Date: Sep 2009
Location: maryland
Posts: 263
Quote:
Originally Posted by SCHMIDTYS View Post
Agreed about the speed sensor. It's located behind and below the starter on top of the trans case. One wire to it and one Allen bolt holding it in. Remove the sensor and clean the debris off the magnet. The debris interferes with the speed signal.
What he said. Cleaning it worked for me a couple of times, then it needed replaced.
fxrglide91 is offline   Reply With Quote Quick reply to this message
Old 11-27-2012, 11:27 PM   #6 (permalink)
Senior Member
 
AlTheKiller's Avatar
 
Join Date: Oct 2012
Location: Texas
Posts: 428
thanks everyone. I still havent had a chance to pull it yet. Its been working again but tomorrow I should have some free time to get it out and cleaned up.
AlTheKiller is offline   Reply With Quote Quick reply to this message
Old 11-28-2012, 08:39 AM   #7 (permalink)
Proud South African
 
Join Date: Jul 2012
Location: Centurion, South Africa
Posts: 52
If it was the speed sensor then your mileage would also be incorrect. Check your trip distance after your trip, if it seems accurate then the problem's with the speedometer itself.
OomD is offline   Reply With Quote Quick reply to this message
Old 12-19-2012, 10:33 PM   #8 (permalink)
Senior Member
 
GlideWide's Avatar
 
Join Date: Aug 2012
Location: Oklahoma
Posts: 867
Give it more gas!!!


Sent from my iPhone using Motorcycle.com App
GlideWide is offline   Reply With Quote Quick reply to this message
Old 12-19-2012, 11:39 PM   #9 (permalink)
Senior Member
 
RicManSr's Avatar
 
Join Date: Nov 2012
Location: Louisiana
Posts: 155
Quote:
Originally Posted by GlideWide View Post
Give it more gas!!!


Sent from my iPhone using Motorcycle.com App
Or shift to second gear!!!


Sent from my iPhone using Motorcycle.com Free App
RicManSr is offline   Reply With Quote Quick reply to this message
Old 12-20-2012, 12:31 PM   #10 (permalink)
UnreconstructedRebel
 
webco2's Avatar
 
Join Date: Jul 2012
Location: Texas
Posts: 3,774
Quote:
Originally Posted by RicManSr View Post
Or shift to second gear!!!


Sent from my iPhone using Motorcycle.com Free App



webco2 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 07:05 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
This site is in no way affiliated with Harley-Davidson
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum