update on iron 883 problem - Harley Davidson Forums: Harley Davidson Motorcycle Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 03-31-2012, 01:16 PM Thread Starter
Pop Punks Not Dead
 
LESSthanDaniel's Avatar
 
Join Date: Feb 2012
Location: Tempe, AZ
Posts: 167
update on iron 883 problem

original post:

Problem.. iron 883

Check the codes and it turns out to be P0152 Rear Oxygen Sensor High

I called the dealership and talked to him about what that meant and he said I could get the stage 1 download but that it might not fix it and that I should probably get a full dyno tune for like $900....

I'm still new and I really don't know what to do. I was told slip ons wouldn't cause this problem and I also get the feeling the dealership just wants all of my money..

I'm about ready to just put the old pipes back on

Anyone have any ideas?

2012 Iron 883 Denim Black
V&H Straight Shots

"Lets Roll"
LESSthanDaniel is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 03-31-2012, 02:25 PM
EVO RULER
 
moose49's Avatar
 
Join Date: Mar 2011
Location: terra dei Limberlost
Posts: 3,721
I'd check the wiring first since you changed the pipes. Then clear and start it again and see if the code resets. This code will turn the chk engine light on. It means the sensor has spent more time than allowed at high voltage.

1- Defective Oxygen Sensor
2- Faulty Oxygen Sensor wiring or connections
3- Shorted Oxygen Sensor Heater element(s)

*CONFORMITY IS JUST A SLOW FORM OF SUICIDE*
******SUPPORT YOUR LOCAL INVADERS*******
********RIP RUBBERDOWN RIDE FREE********
moose49 is offline  
post #3 of 19 (permalink) Old 04-01-2012, 04:50 PM Thread Starter
Pop Punks Not Dead
 
LESSthanDaniel's Avatar
 
Join Date: Feb 2012
Location: Tempe, AZ
Posts: 167
I checked the o2 sensors. Appear to be working fine. No wires were tweaked or anything plus i just changed the slip ons, i never touched the head pipes.

2012 Iron 883 Denim Black
V&H Straight Shots

"Lets Roll"
LESSthanDaniel is offline  
post #4 of 19 (permalink) Old 04-05-2012, 04:35 PM Thread Starter
Pop Punks Not Dead
 
LESSthanDaniel's Avatar
 
Join Date: Feb 2012
Location: Tempe, AZ
Posts: 167
Any ideas????

2012 Iron 883 Denim Black
V&H Straight Shots

"Lets Roll"
LESSthanDaniel is offline  
post #5 of 19 (permalink) Old 04-05-2012, 05:14 PM
I'll help you hide the body
 
misinlink's Avatar
 
Join Date: Mar 2011
Location: S Florida
Posts: 6,795
Well, did you attempt to reset the codes?

Leave the gun. Take the cannoli.



borrowed from gtrman66
Rules:
#1. Post #1: "New to Community"
#2. Buy a HD Service Manual, best $70 you'll spend
#3. Try the search function, we might have already answered your question
#4. Don't post classifieds until you meet the rules
#5. Don't bad mouth dealers until we know you, there are always 2 sides
misinlink is online now  
post #6 of 19 (permalink) Old 04-05-2012, 07:51 PM Thread Starter
Pop Punks Not Dead
 
LESSthanDaniel's Avatar
 
Join Date: Feb 2012
Location: Tempe, AZ
Posts: 167
I haven't even driven it since the lights came on. I didn't want to hurt the bike.

2012 Iron 883 Denim Black
V&H Straight Shots

"Lets Roll"
LESSthanDaniel is offline  
post #7 of 19 (permalink) Old 04-05-2012, 09:15 PM
Senior Member
 
Join Date: Nov 2011
Location: Alabama
Posts: 1,928
Ridding it won't hurt anything. Reset the trouble code, and try again.
bobf is online now  
post #8 of 19 (permalink) Old 04-05-2012, 10:32 PM Thread Starter
Pop Punks Not Dead
 
LESSthanDaniel's Avatar
 
Join Date: Feb 2012
Location: Tempe, AZ
Posts: 167
ok will do. I still feel like its running hot but i'll give it a shot and see if it stays away.

2012 Iron 883 Denim Black
V&H Straight Shots

"Lets Roll"
LESSthanDaniel is offline  
post #9 of 19 (permalink) Old 04-06-2012, 12:41 PM
Addicted Since 2010
 
XL1200R's Avatar
 
Join Date: Jul 2011
Location: Upstate NY
Posts: 7,745
Images: 38
Garage
Quote:
Originally Posted by LESSthanDaniel View Post
ok will do. I still feel like its running hot but i'll give it a shot and see if it stays away.
Could just be a bad sensor.
You could get XIED's, cheap, and will cool it down so even if it doesn't fix the problem they are a good idea.

Link to my Youtube channel. All riding videos. Enjoy.
http://www.youtube.com/user/PittSteelers1345

"Mr. Lahey is this you talking or the liquor?"

"Randy...(takes a swig)...I am the Liquor!!!"
XL1200R is online now  
post #10 of 19 (permalink) Old 04-06-2012, 09:43 PM
EVO RULER
 
moose49's Avatar
 
Join Date: Mar 2011
Location: terra dei Limberlost
Posts: 3,721
Quote:
Originally Posted by LESSthanDaniel View Post
I checked the o2 sensors. Appear to be working fine. No wires were tweaked or anything plus i just changed the slip ons, i never touched the head pipes.
What method did you use to check the sensors?

*CONFORMITY IS JUST A SLOW FORM OF SUICIDE*
******SUPPORT YOUR LOCAL INVADERS*******
********RIP RUBBERDOWN RIDE FREE********
moose49 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome