problem starting - Page 13 - Harley Davidson Forums: Harley Davidson Motorcycle Forum
Reply
 
LinkBack Thread Tools Display Modes
post #121 of 125 (permalink) Old 11-18-2012, 08:13 AM
Retired citizen
 
SCHMIDTYS's Avatar
 
Join Date: Jun 2009
Location: Pt. Wash.,WI
Posts: 14,670
That's what we ride during the winter months in Wisconsin ...

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTYS is offline  
Sponsored Links
Advertisement
 
post #122 of 125 (permalink) Old 11-18-2012, 08:41 AM
Retired citizen
 
SCHMIDTYS's Avatar
 
Join Date: Jun 2009
Location: Pt. Wash.,WI
Posts: 14,670
Plug wires

Another pic from Kris' Sporty showing the "new plug wires" ...
City Limits H-D R.O.# 21027
10mm plug wires
P/N 32092-98A
$19.95
Attached Images
File Type: jpg 8-31-12 thru 11-17-12 & Kris' Sporty 065.JPG (1.01 MB, 43 views)

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTYS is offline  
post #123 of 125 (permalink) Old 11-18-2012, 09:25 AM Thread Starter
Member
 
Join Date: May 2012
Location: Prospect Heights
Posts: 76
Ya the new plug wire Dealer Put in two months ago. Bad Practice City Limits!
majster81 is offline  
post #124 of 125 (permalink) Old 11-18-2012, 07:07 PM
Hit it she goes boom
 
GotGold's Avatar
 
Join Date: Apr 2012
Location: Illinois (Our governors make our plates)
Posts: 4,103
Quote:
Originally Posted by SCHMIDTYS View Post
Another pic from Kris' Sporty showing the "new plug wires" ...
City Limits H-D R.O.# 21027
10mm plug wires
P/N 32092-98A
$19.95

Seriously??? No wonder Kris is so p!ssed... I am sure it was new at one time, just not this year.

"Our lady of blessed acceleration don't fail me now."--- Elwood Blues
GotGold is online now  
post #125 of 125 (permalink) Old 03-31-2013, 09:56 PM Thread Starter
Member
 
Join Date: May 2012
Location: Prospect Heights
Posts: 76
I wonder if anyone is still following this thread. After 4 months of Idle I took the sporty out. I put new set of plug wires and some VH baffles to tone things down. First time trying to start it I flooded it thinking it would be thirsty after all those months, but it wasn't. Cleaned up the plugs and half choke whammm it started with it's nice deep sound. I warmed it up and took it for 25+ mile run - man, it was nice ridin'. Bike is very responsive and it's mid and low range is back because of the baffles. Thank you all who tried helping me with my issues. I am back on the road.
majster81 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome