Anyone sick of pics of 10" PYO on SG's? - Page 4 - Harley Davidson Forums: Harley Davidson Motorcycle Forum
Reply
 
LinkBack Thread Tools Display Modes
post #31 of 36 (permalink) Old 12-02-2012, 08:02 PM Thread Starter
Retired Army
 
hdrolling's Avatar
 
Join Date: Jul 2009
Location: Fayetteville, NC
Posts: 175
Images: 149
Quote:
Originally Posted by Labradaddy View Post
Won't those make your mirrors pretty much useless?
I see my old thread from 2010 was brought back up, but no my mirrors being upside down work just fine. Made some changes since iv'e added the bars.







2010 Street Glide, SE 120R 125HP/125TQ
hdrolling is offline  
Sponsored Links
Advertisement
 
post #32 of 36 (permalink) Old 12-02-2012, 10:18 PM
Senior Member
 
sthill's Avatar
 
Join Date: Sep 2011
Location: Chicago
Posts: 135
Images: 34
Garage
Quote:
Originally Posted by SG103 View Post
What size are those?
12"-ers
sthill is offline  
post #33 of 36 (permalink) Old 12-03-2012, 06:06 PM
Senior Member
 
SG103's Avatar
 
Join Date: Jul 2011
Location: Upstate NY
Posts: 163
Quote:
Originally Posted by sthill View Post
12"-ers
Thanks.

2011 Street Glide
2006 Texas Chopper
SG103 is offline  
post #34 of 36 (permalink) Old 12-03-2012, 07:07 PM
Senior Member
 
UDawg's Avatar
 
Join Date: Aug 2010
Location: Utah
Posts: 157
Quote:
Originally Posted by hdrolling View Post
Yes these are the 10" baggernation Paul Yaffe Original monkey bagger bars i believe there called. Black or Chrome.
The install took me about 6-7 hours, BUT I have an engine light and no cruise control. I was able to ride it and it is very comfortable just like everyone said. I'm going to do some trouble shooting to see if i grounded a wire internally somewhere wire wiring them. The job is very easy but i think i russhed it a little because it was easier than i thought and i had the bike apart and everything for the wiring in the house in the A/C in about an hour. The wiring took about 3 hours with a lot of cussing and trying differnt things. And then about 2 1/2 to 3 hours putting it back together with poor lighting, i should have waited until morning but was to excited.
Turned the bike on and the engine light came on but started easy and ran good. I took it for a ride after making sure all my lights were working and thats when i saw that the cc wasn't working. Ill get it figured out during the four day weekend i have this weekend, and worse case i'll take it to the dealer now that 95% of the work is done and see if they have any tricks.
Looks GREAT! Did you have to change any cables or brake lines?

2014 SGS
Amber Whiskey
UDawg is online now  
post #35 of 36 (permalink) Old 12-03-2012, 07:35 PM
ROOAADDD KINGGGGG
 
Rohan's Avatar
 
Join Date: Jun 2011
Location: Arizona
Posts: 2,018
Garage
NICE! I have 12's on my SG and I love the look and feel.


-Rohan
Rohan is offline  
post #36 of 36 (permalink) Old 12-04-2012, 09:43 AM
Member
 
Join Date: Dec 2012
Location: Ohio
Posts: 48
Dig those bars. Can't wait to change my rk's beach bars out for some mini apes.


Sent from my iPhone using Motorcycle.com Free App
evilimprdr is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome