Radio audio cutting out - Harley Davidson Forums: Harley Davidson Motorcycle Forum
Harley-DavidsonForums.com is an independent enthusiast website owned and operated by VerticalScope Inc. Harley-DavidsonForums.com is not sponsored by or in any way affiliated with Harley-Davidson Inc.. The Harley Davidson names and logos are trademarks owned by Harley-Davidson Inc.

Go Back   Harley Davidson Forums: Harley Davidson Motorcycle Forum > Specific Model Areas > Touring General Discussions

» Insurance
» Our Partners
»ATV Reviews
»Motorcycle Games
Reply
 
LinkBack Thread Tools Display Modes
Old 06-23-2011, 09:33 PM   #1 (permalink)
Member
 
shortride's Avatar
 
Join Date: Jun 2011
Location: Oklahoma
Posts: 37
Garage
Radio audio cutting out

I could use some help figuring out why the audio cuts out completely on the stock radio on my '09 Ultra Classic before I have to pay some outragious labor cost at the dealer.

The audio would sometimes come back when I flipped the 3-way speaker switch or turn the power off. The 3-way switch has been replaced. I took the outer fairing off to see if I could see anything maybe with a loose connection with any of the speaker wires. I've also got the Hogtune tweeters. A few of the speaker connections seem to be looser that I thought they should be so I crimped them a bit.

The strangest part is that I can ride all day long sometimes and the audio will not cut out at all. Other days it may do it 3 or 4 times and sometimes it will do it a dozen times within a 10 mile ride. What's even stranger than that is that it will do it more often at 65 mph than it will at 50 mph because I tested it.

I know as well as I'm typing this that someone else has got to have had this identical issue.

I'm no radio technican by any stretch of th imagination but I don't think it's in the radio itself.
shortride is offline   Reply With Quote Quick reply to this message
Old 06-24-2011, 09:03 AM   #2 (permalink)
Senior Member
 
Baldy Locks's Avatar
 
Join Date: Nov 2010
Location: Wisconsin
Posts: 139
Images: 2
Ive read some radio posts in the past and one suggestion was to update the software. Not sure if you have the Harmon Cardon like my 07 StreetGlide but it may be a good place to start.
I found it on the Harley Davidson website, searched under Harmon Cardon radio software update. Instructions say to save to disc then print out and follow very easy instructions to load disc into and update the radio.
Hope I was some help.
__________________
There's no cure for dumb but it sure thins the herd
Baldy Locks is offline   Reply With Quote Quick reply to this message
Old 06-24-2011, 09:09 AM   #3 (permalink)
Retired citizen
 
SCHMIDTYS's Avatar
 
Join Date: Jun 2009
Location: Pt. Wash.,WI
Posts: 13,120
Also make sure your CB is off , the squelch will cut the radio sound off if a signal is detected .
__________________
Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTYS is offline   Reply With Quote Quick reply to this message
Old 06-24-2011, 11:26 AM   #4 (permalink)
Junior Member
 
Join Date: Aug 2009
Location: lasvegas nevada
Posts: 5
check out iron cross audio web site....he has the fix
lasvegasrick is offline   Reply With Quote Quick reply to this message
Old 06-24-2011, 04:54 PM   #5 (permalink)
Junior Member
 
Join Date: Mar 2011
Location: Texas
Posts: 4
I'm with Schmidtys...I was experiencing the same thing on my 07 UC. Rolled the squelch up on my CB or turned it off, and that did the trick.
buckeyetx is offline   Reply With Quote Quick reply to this message
Old 09-06-2011, 07:47 PM   #6 (permalink)
Member
 
Deck's Avatar
 
Join Date: May 2010
Location: Canada
Posts: 35
having the same issue, poor radio signal. went on a week ride, radio worked great but now I have a weak signal. CB is off
Did you get a fix shortride? has anyone else had this problem ('08 Ultra)
Deck is offline   Reply With Quote Quick reply to this message
Old 09-12-2011, 05:31 PM   #7 (permalink)
Junior Member
 
06Ultraglide's Avatar
 
Join Date: Sep 2011
Location: Sacramento, Ca
Posts: 1
My buddy is on his 5th radio, all under warranty on his 09 Ultra Classic. He's had intermittant on -off, static, display blurred, real bad static, and would not stay on. Luckily, I guess, he bought the 5 year extended warranty. Unfortunately, instead of replacing it with a new one, the dealer is sending the old one in to get fixxed. Im goin aftermarket on my 06 Ultra, my radio gets scratchy/distorted after about 5 minutes.
06Ultraglide is offline   Reply With Quote Quick reply to this message
Old 09-12-2011, 05:38 PM   #8 (permalink)
Senior Member
 
TwoFer's Avatar
 
Join Date: Feb 2010
Location: Texas
Posts: 401
Images: 5
Garage
Quote:
Originally Posted by SCHMIDTYS View Post
Also make sure your CB is off , the squelch will cut the radio sound off if a signal is detected .
Yea, and I found out you can't sing along to the music either!
__________________
2013 FLHX Ember Red Sunglow

2011 FXDWG Orange & Black
TwoFer is offline   Reply With Quote Quick reply to this message
Old 11-29-2012, 03:47 PM   #9 (permalink)
Junior Member
 
Join Date: Nov 2012
Location: Ellicott City, MD
Posts: 1
I had a problem with my radio switching back & forth between the headsets & speakers. It would switch at "random times" regardless of where the selector switch was set, & got progressively worse. After some troubleshooting, I determined the ground was corroded & the lack of contact/ground was causing the feedback in the various circuits.... There are two ground points under the seat on on the forward left side. Cleaned them both up (although the "clean" ground...rearward of the two...was the one causing the problem) & everything works fine now.

Brad
2008 FLHTCU Anniversary
NuWaveBrad is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -5. The time now is 06:09 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
This site is in no way affiliated with Harley-Davidson
Motorcycle News, Videos and Reviews
Honda Grom Forum Harley Davidson Forum Honda 600RR Forum Kawasaki Forum Yamaha R6 Forum Yamaha FZ-09 Forum
1199 Panigale Forum Roadglide Forum Honda CBR1000 Forum Vulcan Forum Yamaha R1 Forum Yamaha R3 Forum
Ducati Monster Forum Harley Forums Honda CBR250R Forum ZX10R Forum Star Raider Forum Yamaha Viking Forum
Suzuki GSXR Forum V-Rod Forums Honda Shadow Forum Kawasaki Motorcycle Forum Star Warrior Forum KTM Duke 390 Forum
SV650 Forum BMW S1000RR Forum Honda Fury Forum Kawasaki Versys Forum Drag Racing Forum Ducati 899 Panigale Forum
Suzuki V-Strom BMW K1600 Triumph Forum Victory Forums Sportbikes BMW NineT Forum
Volusia Forum BMW F800 Forum Triumph 675 Forum MV Agusta Forum HD Street Forum Suzuki GW250 Forum
Yamaha Motorcycles Victory Gunner Forum Honda Vultus Forum HD LiveWire Forum Ninja H2 Forum Ducati Scrambler Forum Kawasaki Ninja 250SL Forum