S&S v111 installed in my '97 Roadking - Page 5 - Harley Davidson Forums: Harley Davidson Motorcycle Forum
Reply
 
LinkBack Thread Tools Display Modes
post #41 of 46 (permalink) Old 12-10-2012, 07:51 PM
Junior Member
 
Join Date: Oct 2012
Location: Madison, WI
Posts: 12
Quote:
Originally Posted by 29roadking View Post
No, but the mechanic was maladjusted.
And there are way too many of them.
This was the cause of my learning this beast inside and out.
WI Bob is offline  
Sponsored Links
Advertisement
 
post #42 of 46 (permalink) Old 12-11-2012, 12:06 AM
Senior Member
 
Join Date: Dec 2011
Location: Rockvale, TN
Posts: 131
Glad you got the bike back in one piece again (sort of). If a dealer can't adjust a Super E carb I would seriously doubt any other hands on work they may have attempted. Sounds like that bike needs to be thoroughly checked out before anyone rides it, either by you or some trusted wrench.

HandOverFist is offline  
post #43 of 46 (permalink) Old 12-11-2012, 12:22 PM Thread Starter
Junior Member
 
Join Date: Sep 2012
Location: lake city, sc
Posts: 25
Thank all of you for the comments. This is the best engine I have ever sat over and I have been riding since '61. I would do it over again with S&S, just with another dealer, it is a good decision. Much higher quality than the HD motor is.

Oh, also, this engine gets great gas mileage. I was afraid it would drop to 31-33 mpg. I'm getting around 42 initially. I'll know more after a couple thousand miles.
29roadking is offline  
post #44 of 46 (permalink) Old 12-14-2012, 10:14 AM
ROOAADDD KINGGGGG
 
Rohan's Avatar
 
Join Date: Jun 2011
Location: Arizona
Posts: 2,018
Garage
Glad everything got sorted out. Happy riding!


-Rohan
Rohan is offline  
post #45 of 46 (permalink) Old 12-22-2012, 07:45 PM
Member
 
Join Date: Aug 2011
Location: Iowa
Posts: 34
Images: 2
I've been watching this story since the first post you put up and I'm glad it was a good engine, since I just bought a S & S V96 to put in my FLHS. I almost went with a 111" but decided on the 96". I'm going to do the install myself so we'll see how that goes.
Sputnik is offline  
post #46 of 46 (permalink) Old 01-10-2013, 09:21 AM Thread Starter
Junior Member
 
Join Date: Sep 2012
Location: lake city, sc
Posts: 25
Well, I finally took the bike to, The Original Bad Guys, in Columbia, SC. This was the best decision I made during the entire ordeal. The owner Scott is really an S&S expert. Believe this or not, within 10 minutes after taking it in the shop he told me what was wrong with it. It was the ignition causing it to skip and jerk at low speeds.

No I haven't posted this on here yet, because when I got it back, it would run great above 50 mph, but below it was aggravating. I called S&S and they told me to find a dealer and I was lucky enough to choose The Original Bad Guys Shop. He fixed the ignition and found that the Harley shop, Doug's of Florence, didn't line the engine right and had misinstalled the top motor mounts. I am very grateful for Kevin at S&S for referring me and and most of all for Scott at Original Bad Guys, 803-738-9339 for the help.

Hey, the V111 is the ticket, this engine is beautiful and very powerful.

Thank You Guys
Sam Wingate
29roadking is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome