Harley Davidson Forums: Harley Davidson Motorcycle Forum - View Single Post - Help - Bike Intermittent Stopping
View Single Post
post #1 of (permalink) Old 08-12-2019, 02:39 AM Thread Starter
harleyfreak89
Junior Member
 
Join Date: Aug 2019
Posts: 6
Help - Bike Intermittent Stopping

Hi guys. Need some help here on some maybe cheap rectification before I get to Harley dealership which is quite far from the place I live. Only code it is giving is P1632 odometer learned up. I checked the obvious battery connections and looked for any loose wires but didn't find anything.

Speed sensors dirty or faulty? Ignition switch issue?

Anything that I can check easily without loosing pennies by sending to dealership as I need to tow the bike to avoid break down in middle of road.


Issue:
After a 2000km ride to different country, on the way back I have issues with the bike showing sign of loss of power. Thank god no issue while reaching destination And I manage to reach home safely. My speedo dropped to 0 but only for a moment and the bike started back up and speedo came back.

I knew something was but I manage to ride below 100km hr to reach home safely. Need to pull the clutch and rev to make sure the bike is up to speed.



Rectification attempt done myself:

1. I have New battery cables and Battery changed prior to the ride. Thinking maybe the battery is an issue I took the effort to reclaim a new battery from dealer thinking it was a battery issue. Changed it but issue still persists. Bike jerking and showing sign of stalling upon reving up the throttle and will die during at traffic lights or whenever I pull the clutch.


2. Changed my spark plugs and gave it a good service after the long ride.


After performing all rectification above, my dyna spitting and sputtering still persists . It's like every time it would sputter the bike was actually shutting off because the abs light would come on and the speedo would drop to 0 then catch back up.



Only code it is giving is P1632 odometer learned up.

I checked the obvious battery connections and looked for any loose wires but didn't find anything.




Sorry for the long post but any help would be great. Thanks.
harleyfreak89 is offline  
 
 
For the best viewing experience please update your browser to Google Chrome