Iron 883N don't crank - Harley Davidson Forums: Harley Davidson Motorcycle Forum
 3Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 09-04-2019, 12:44 AM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 9
Iron 883N don't crank

I own 2015 Harley davidson iron 883N. Not starting after 1 month storage. Battery was dead. Replaced battery. Still not starting. Lights,fulepump,indicators,dial etc wrkg. But when start button is pressed, no solenoid click. Checked solenoid trigger wire. Shows 1.5 volts insted of 12 volt when start button is pressed.Tried to connect solenoid trigger wire directly to battery positive terminal. Engine cranks good.Traced the trigger wire. Found it going to BCM.Feels like BCM faulty. Diag shows BCM error p2121 & p2271. Cleared both error . Still no luck. Also my new battery showing 11.7 volt when connected to bike. Dont know if its normal.

Any other way to start bike directly with existing BCM fault. Pls
Rajeevks is offline  
Sponsored Links
Advertisement
 
post #2 of 19 (permalink) Old 09-04-2019, 07:02 AM
Senior Member
 
Join Date: Nov 2011
Location: Costa Rica
Posts: 3,407
Your battery is LOW voltage should be 12.6 or higher. Bench charge the battery to full chargw and try again. Bet you didn't fully charge the new battery, before installing.
bobf is online now  
post #3 of 19 (permalink) Old 09-04-2019, 11:31 AM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 9
It's a new battery. Moreover the trigger wire of solenoid must not be as low as 1.5 volts even if battery has low voltage.
Also atleast solenoid must click. 11.5 volt may not be able to start engine but atleast click the solenoid.
Rajeevks is offline  
 
post #4 of 19 (permalink) Old 09-04-2019, 06:11 PM
Just Ride
 
FritzHD's Avatar
 
Join Date: Nov 2010
Location: West Coast Florida
Posts: 3,024
Ground wire/negative cable might be the problem

2010 FLTRX Wimmer Better Sucker,Stage 1,Xied's,no cat,fatstick with open end cap. 2004 Dyna Lowrider Harley Heavy Breather,Stage 1,Screaming Eagle mufflers.1996 FXDS-CONV S&S E.Screaming Eagle ignition,V&H Short shots. 1978 Strokershovel Lowrider 100 inches. 1974 Suzuki GT750 Lemans (Water Buffalo)
FritzHD is online now  
post #5 of 19 (permalink) Old 09-04-2019, 11:16 PM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 9
Cleaned both terminal with brush. Cleaned the body ground. Tested volt at starter. It's 11 volt.
baggerboy likes this.
Rajeevks is offline  
post #6 of 19 (permalink) Old 09-05-2019, 07:14 AM
Senior Member
 
Join Date: Nov 2011
Location: Costa Rica
Posts: 3,407
If you only have 11 volts, the battery is low, bench charge it with a battery charger, not a tender, a real charger, then try again. The "resting voltage should be 12.6 or so.
bobf is online now  
post #7 of 19 (permalink) Old 09-05-2019, 10:43 AM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 9
I charged the new battery whole day .When battery is disconnected it shows 12.6 volts. As soon as it's connected to bike it drops to 11.7 volts.....
Is it possible that my bike has a short ckt. How to test it?
Rajeevks is offline  
post #8 of 19 (permalink) Old 09-05-2019, 02:36 PM
Senior Member
 
Join Date: Nov 2011
Location: Costa Rica
Posts: 3,407
If the battery is fully charged it should not drop as soon as it is hooked up. What are you charging the battery with? Either the battery is never getting fully charged (if you are using a Tender type charger) or the new battery is defective(would not be the first). If you have a auto parts store near you, take battery there and have it load tested. If you had a short circuit on your bike, that was bad enough to draw the battery down as soon as you hook it up, it would spark really badly when you connected the battery. I would bet money, the battery is not charged, or is defective.
Smoketown$1 and 1/2 Ton like this.
bobf is online now  
post #9 of 19 (permalink) Old 09-06-2019, 02:39 PM
Senior Member
 
MFXDB's Avatar
 
Join Date: Aug 2010
Location: SE Penna.
Posts: 460
Charge up the battery as best you can, then get it load tested as suggested above.
If you had a short you would blow a fuse or get a big spark.

2007 Street Bob
ThunderMax
DK 587
Ohlins
MFXDB is offline  
post #10 of 19 (permalink) Old 09-08-2019, 09:43 AM Thread Starter
Junior Member
 
Join Date: Sep 2019
Posts: 9
Ok I'll try this also and get back to you guys soon. Thanks
Rajeevks is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome