Fuel pump - Page 5 - Harley Davidson Forums: Harley Davidson Motorcycle Forum
 9Likes
Reply
 
LinkBack Thread Tools Display Modes
post #41 of 59 (permalink) Old 04-23-2019, 11:25 AM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 28
Fuel pump not getting current

Used light tester to test all fuse ports, all gave power except fuel pump fuse spot?
Tiolou21 is offline  
Sponsored Links
Advertisement
 
post #42 of 59 (permalink) Old 04-23-2019, 11:50 AM
Just Ride
 
FritzHD's Avatar
 
Join Date: Nov 2010
Location: West Coast Florida
Posts: 2,936
Was your run/stop switch set to run? Change fuse?

2010 FLTRX Wimmer Better Sucker,Stage 1,Xied's,no cat,fatstick with open end cap. 2004 Dyna Lowrider Harley Heavy Breather,Stage 1,Screaming Eagle mufflers.1996 FXDS-CONV S&S E.Screaming Eagle ignition,V&H Short shots. 1978 Strokershovel Lowrider 100 inches. 1974 Suzuki GT750 Lemans (Water Buffalo)
FritzHD is online now  
post #43 of 59 (permalink) Old 04-23-2019, 12:21 PM
Retired citizen
 
SCHMIDTY's Avatar
 
Join Date: Jun 2009
Location: Port Wash.,WI
Posts: 21,212
Garage
FYI, the fuel pump circuit is only active for 3 seconds then shuts down after the engine starts !

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTY is offline  
 
post #44 of 59 (permalink) Old 04-23-2019, 03:32 PM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 28
Yes, tried with power on and off
Tiolou21 is offline  
post #45 of 59 (permalink) Old 04-23-2019, 03:37 PM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 28
Plus tested fuse ok, and I was told about the 3 sec rule from, norm9278, or baggerboy
Tiolou21 is offline  
post #46 of 59 (permalink) Old 04-23-2019, 03:40 PM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 28
The fuel pump, fuse port has no power
Tiolou21 is offline  
post #47 of 59 (permalink) Old 04-23-2019, 03:59 PM
Senior Member
 
norm9278's Avatar
 
Join Date: Apr 2016
Posts: 433
Quote:
Originally Posted by Tiolou21 View Post
The fuel pump, fuse port has no power
Ok, no power to either side of the fuse AT KEY ON, correct?
If so, try switching the relays around. They are the two small boxes plugged into the fuse panel, both are the same, just switch them.
Also, run a hot wire from the battery + to the fuel pump fuse. Does the pump run when you do that?

Sent from my coal fired bag phone using Tapatalk
baggerboy likes this.
norm9278 is online now  
post #48 of 59 (permalink) Old 04-25-2019, 03:11 PM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 28
Ok norm switch nothing,wire from battery to fuse port neg, and poz side nothing, used two wires nothing, couple days ago when using tester fule pump fuse port did show current one time and one time only
Tiolou21 is offline  
post #49 of 59 (permalink) Old 04-25-2019, 03:36 PM Thread Starter
Junior Member
 
Join Date: Apr 2019
Posts: 28
Scratch every thing first time trying to diagnose, put neg tester wire on neg side battery, put tester in fuel pump fuse port, got a light norm9278
Tiolou21 is offline  
post #50 of 59 (permalink) Old 04-25-2019, 03:37 PM
South GA Redneck
 
baggerboy's Avatar
 
Join Date: Apr 2011
Location: Soperton, GA
Posts: 3,790
Images: 4
Garage
Sounds like you may need to check the chassis grounds. If you didnt get voltage u til you went straight to battery for ground


Sent from my iPhone using Tapatalk
baggerboy is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help!!! Fuel supply tube and fuel rail spraying out fuel!!! Luceroryan Fuel Systems 5 02-27-2018 06:28 PM
2001 Fuel Injection Fuel Pump?? flhtcCarl Fuel Systems 12 12-03-2010 08:47 AM
02 FLSTFI Fuel Pump pw16k10 Fuel Systems 0 03-19-2009 03:52 PM
fuel pump issue Hornet745 Electrical 4 10-25-2008 02:34 PM
Road king fuel pump line leaks(holes) docroz Touring General Discussions 3 05-15-2007 07:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome