Fuel Sending Unit Help - Harley Davidson Forums: Harley Davidson Motorcycle Forum
 2Likes
  • 2 Post By Rknob
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-20-2019, 11:17 AM Thread Starter
Junior Member
 
Join Date: Aug 2019
Posts: 3
Fuel Sending Unit Help

I am new to the forum and would appreciate any advice.

I just replaced my fuel check valve assembly on my 2013 Fat Boy Lo. It all went well (or so I thought) with no leaks and it run fine, but now my LED fuel gage reads low, one light only, even with 4 gallons of gas in the tank. When I turn on the ignition, the fuel gage lights up with all lights on and then drops to the one light.

I did I miss something like having to reset the LED fuel gauge or possibly not connected the gauge correctly? I would truly love to avoid removing everything again to see if somehow the check valve assembly hose is blocking the sending unit. Any advice or suggestion would be appreciated.
Rknob is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-20-2019, 11:43 AM
South GA Redneck
 
baggerboy's Avatar
 
Join Date: Apr 2011
Location: Soperton, GA
Posts: 3,869
Images: 4
Garage
I would check to see if the sending unit got damaged when changing the check valve. Also make sure the electrical connections are good.


Sent from my iPhone using Tapatalk
baggerboy is offline  
post #3 of 5 (permalink) Old 08-22-2019, 07:29 AM Thread Starter
Junior Member
 
Join Date: Aug 2019
Posts: 3
Thank you, I'm going to check both today but I hope it is a loose connection.
Rknob is offline  
 
post #4 of 5 (permalink) Old 08-23-2019, 11:55 AM Thread Starter
Junior Member
 
Join Date: Aug 2019
Posts: 3
The problem was a loose connection in the tank. All is good now, thanks again.
Kainam and baggerboy like this.
Rknob is offline  
post #5 of 5 (permalink) Old 08-23-2019, 12:17 PM
South GA Redneck
 
baggerboy's Avatar
 
Join Date: Apr 2011
Location: Soperton, GA
Posts: 3,869
Images: 4
Garage
Thanks letting us know how it turned out!


Sent from my iPhone using Tapatalk
baggerboy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome