Looking for a lil help - Harley Davidson Forums: Harley Davidson Motorcycle Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 07-28-2019, 09:15 AM Thread Starter
Junior Member
 
John Grimsby's Avatar
 
Join Date: Jul 2019
Posts: 0
Looking for a lil help

New to the group looking for some words of wisdom 06 ultra I have a high idle from time time to time when bike is warm come to a stop light stop and all goes back to normal problem is bike has hesitations when trying to take off it only acts up after a high idle I have replaced almost every thing.

Any chance some of you have some advice on this?
John Grimsby is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 07-28-2019, 09:47 AM
Retired citizen
 
SCHMIDTY's Avatar
 
Join Date: Jun 2009
Location: Port Wash.,WI
Posts: 21,421
Garage
Quote:
Originally Posted by John Grimsby View Post
New to the group looking for some words of wisdom 06 ultra I have a high idle from time time to time when bike is warm come to a stop light stop and all goes back to normal problem is bike has hesitations when trying to take off it only acts up after a high idle I have replaced almost every thing.

Any chance some of you have some advice on this?
So what did ya replace ? I'll give advice when ya offer more info.

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTY is offline  
post #3 of 7 (permalink) Old 07-28-2019, 03:36 PM Thread Starter
Junior Member
 
John Grimsby's Avatar
 
Join Date: Jul 2019
Posts: 0
All sensors on the motor,fuel pump,filter,regulator.
This is over the last 6 months it only happens when bike is hot
John Grimsby is offline  
 
post #4 of 7 (permalink) Old 08-05-2019, 03:29 PM
Senior Member
 
Haus's Avatar
 
Join Date: May 2018
Location: Lockport, IL
Posts: 153
You sure its not just the EITMS being enabled?


Sent from my iPhone using Tapatalk
Haus is offline  
post #5 of 7 (permalink) Old 08-06-2019, 06:19 AM
Retired citizen
 
SCHMIDTY's Avatar
 
Join Date: Jun 2009
Location: Port Wash.,WI
Posts: 21,421
Garage
Quote:
Originally Posted by John Grimsby View Post
All sensors on the motor,fuel pump,filter,regulator.
This is over the last 6 months it only happens when bike is hot
I would try cleaning the IAC pintle and port with break clean or carb spray. The port is in the top of the throttle body venturii. Spray into the port and cycle the ignition several times until the cleaner runs clear.

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTY is offline  
post #6 of 7 (permalink) Old 08-06-2019, 10:02 AM
Senior Member
 
Haus's Avatar
 
Join Date: May 2018
Location: Lockport, IL
Posts: 153
Quote:
Originally Posted by SCHMIDTY View Post
I would try cleaning the IAC pintle and port with break clean or carb spray. The port is in the top of the throttle body venturii. Spray into the port and cycle the ignition several times until the cleaner runs clear.


We had this issue on a 2012 King this wknd. Messed around with the clip that plugs into the throttle body and went down. Found a broken wire (has a tight bend it the harness). Spliced in a new temp wire and worked for @ 150 miles until acted up again. Limped to a dealer and said was a known issue (the pins?). We experienced loss of throttle too. Talk to Silverback (was his bike). He can give you more details on what was told to him.


Sent from my iPhone using Tapatalk
Haus is offline  
post #7 of 7 (permalink) Old 08-07-2019, 08:44 AM
Keep on Ridin
 
Silverback's Avatar
 
Join Date: Mar 2012
Location: Baton Rouge, LA
Posts: 8,037
Images: 14
Garage
I think the 06 is still a cable operated throttle system. My problem is related to electronic throttle body issues. I think Schmidtys advice is appropriate on this model.




Sent from my iPhone using Tapatalk



"There's no sensation to compare with this
Suspended animation, a state of bliss
" --Pink Floyd
** This line seems to come to mind often while I'm riding.

"Men do not quit playing because they grow old. They grow old because they quit playing." --Oliver Wendell Holmes

"And miles to go before I sleep
...and miles to go before I sleep." -- Robert Frost

If you give up drinking, you don't live longer...it just seems longer
Silverback is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome