cant get clutch to work. ? 2007 sporster 1200 cust. - Harley Davidson Forums: Harley Davidson Motorcycle Forum
 2Likes
  • 1 Post By baggerboy
  • 1 Post By SCHMIDTY
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 08-22-2019, 09:43 AM Thread Starter
Junior Member
 
Join Date: Aug 2019
Location: Bedford,In
Posts: 2
Unhappy cant get clutch to work. ? 2007 sporster 1200 cust.

changed clutch pack. took spring in middle out. rechecked everything 4 X. nothen. pull clutch arm on ball and ramp moves forward but dont come back. with my hand i can move ball and ramp,but cable only moves one way. cable dont seem to be broke though.?
Red rider is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 08-22-2019, 01:31 PM
South GA Redneck
 
baggerboy's Avatar
 
Join Date: Apr 2011
Location: Soperton, GA
Posts: 3,860
Images: 4
Garage
Gotta go back and re-check everything. If the cable is moving on both ends, cable isnt froze or broke. Something isnt right with the clutch assembly or the ball/ramp assembly.


Sent from my iPhone using Tapatalk
Kainam likes this.
baggerboy is online now  
post #3 of 5 (permalink) Old 08-25-2019, 07:36 AM Thread Starter
Junior Member
 
Join Date: Aug 2019
Location: Bedford,In
Posts: 2
thanks, inside of my clutch baskit the factory spring the ribits came out. I am so lost on this,seems like the ramp should catch on something. But i put a york clutch kit back in and added 2 friction and a steel to replace the middle spring. but when all back together nothing.?
Red rider is offline  
 
post #4 of 5 (permalink) Old 08-25-2019, 07:46 AM
Banned
 
Kainam's Avatar
 
Join Date: Oct 2006
Location: Z^2 + C
Posts: 36,058
Images: 150
Garage
Sounds like it wasn't adjusted right.

Mala Ipsa Nova
Psalm 144:1 Luke 22:36

'05 Carbed Night Train
111 rwhp, 112 rwtq
Best 1/4 ET 12.557s
Best 1/4 MPH 108.59

http://weathersticker.wunderground.c...ansas_City.gif
Kainam is online now  
post #5 of 5 (permalink) Old 08-25-2019, 07:46 AM
Retired citizen
 
SCHMIDTY's Avatar
 
Join Date: Jun 2009
Location: Port Wash.,WI
Posts: 21,490
Garage
Are you sure the balls didn't fall out of the ramp assy. ?
Go to RonniesPartsFinder.com and look your bike part list up to see if you have everything assembled in order.
baggerboy likes this.

Disclaimer : Don't believe anything I say unless you are absolutely sure that I know what I'm talking about .
SCHMIDTY is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Harley Davidson Forums: Harley Davidson Motorcycle Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome