Harley Davidson Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-6 of 7 Results
  1. Trans/Primary
    Hello, Long time Triumph owner, first time Harley owner. I recently bought a 2009 HD Sportster for the low because the engine wouldn’t turn over due to a broken flywheel. I was told it would cost less to just swap the entire engine instead of replacing the flywheel (if I could find a...
  2. Sportster General Discussions
    2009 Sportster formerly an 883 now a 1275. Recently it will not start when it gets got, you have to let it cool for 1-2 hours before it will start. The fuses are good, relays are good, starter is getting power but the command wire to the starter is reading 0.0 volts when hot but 12.3 when cool...
  3. Engine
    Hi there looking for advice or someone who has had similar problem , I bought a 2011 wide glide last month , heard it run test drive it bought it drove it home no issues. took tank off for it to get painted , had all fuel lines disconnected drained fuel eveything was good went back on good, got...
  4. Electrical
    Hey guys, New to posting on these forums but Ive searched thru everything on a few different pages and cant find anything. Here's my issue - 2002 Harley Electra glide classic with the delphi system. Bike has been to 3 different shops for a custom bagger build and it came to me. I've went...
  5. Electrical
    I am in the middle of a handlebar job where I extended the wires and cables. Got the bars on and connected all the wires and everything is working except the start switch. Inspected the wires and nothing is broken or pinched. Checked the battery and the fuses and all looks good. I did end up...
  6. Electrical
    Has new fully charged batt with 500ca.has new starter, regulator, starter cables and starter relay.bike has only 14k miles was running fine.got home shut off.over nite it was damp and after that bikes lights work.go hit start button does nothing.sometimes if bike got wet over night it would...
1-6 of 7 Results
Top