Harley Davidson Forums banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-13 of 13 Results
  1. Electrical
    I have a 2018 Harley Davidson Fat Bob 114 that last year at the end of riding season the ACR blew right off the top of the rear cylinder and i had to wait for months to gets part tore bike down got it replaced just to find out the battery was dead was at a buddys shop for winter storage and i...
  2. General Service and Repair
    Hello everyone! Im new to the form, but not new to motorcycles. I’ve been riding for about 20 years. Im on my second Harley. 2004 Ultra Classic. About a month ago, my Harley just stopped starting. I first thought it was the battery, so I replaced the battery. Still didn’t start. When I press...
  3. Trans/Primary
    I have a 2009 Harley road king with 23k miles on it (96CI).Long story short, last year I was going to head on a trip and went to change my fluids and found a bug chunk of metal on my primary drain plug. Pulled the cover and found a missing tooth on the starter ring gear. This winter i pulled her...
  4. Electrical
    Background: 03 wideglide. I am second owner and have had it since 2014. 11500 miles, had 9500 on it went I bought it. So it sits in the my shop on a tender allot. Only ridden in the rain once! Big bore kit installed when fairly new by HD dealer. Problem: Starter will spin, pinion will engage...
  5. Sportster General Discussions
    2009 Sportster formerly an 883 now a 1275. Recently it will not start when it gets got, you have to let it cool for 1-2 hours before it will start. The fuses are good, relays are good, starter is getting power but the command wire to the starter is reading 0.0 volts when hot but 12.3 when cool...
  6. General Motorcycle Related
    I need help figuring out how I can get my 2006 Harley Davidson XL Sportster 1200 Custom running again, she’s in excellent condition and starts right up with no problems… well up until this happened. After riding for about an hour, I got home parked on the driveway a few (maybe 3) hours later I...
  7. Electrical
    I have the 73 XLH and the starter relay just won’t send electricity to the solenoid. I was using the old school mechanical relay and had one go bad, replaced it with the same mechanical one, It lasted about a week and shit the bed. When I tested it I get 12.1 off the red BAT wire, 11.5 off the...
  8. Softail General Discussions
    I'm losing my mind!!! '99 Fatboy, new All Balls starter, like 20 miles new, brand new jackshaft assembly, and took the battery to the local Auto Zone and it checked out good. Here's the mindf**$...I get the bike to fire up, all's well, then if I stop somewhere and try to start it back up, just...
  9. Classics General Discussions
    What’s up all! First post, I’m a newbie. I’m sure I’ll get crushed from stupidity. But after the crushing maybe I can get help with the problem! Lol. Sold my sportster, graduated to 96 Electra and I absolutely love it. Check my fluids, changed my oil, popped in a new battery. Everything seems...
  10. Electrical
    I’ve got the 73 XLH and I had my starter solenoid go bad at Christmas time, Got hung up and smoked up a little and wouldn’t disengage until I pulled the battery off. I finally got the new one and dropped her but I’m not getting any mechanical action beyond the starter relay, I’ve got 13V coming...
  11. General Motorcycle Related
    I have a 73 XLH. I went out the other day to see how weak my battery was so I could go for a ride and when I turned my key the battery was cranking but not enough to fire, and then when I cut the key and kill switch it kept cranking and I got a little bit of smoke so I disconnected the terminal...
  12. Electrical
    Has new fully charged batt with 500ca.has new starter, regulator, starter cables and starter relay.bike has only 14k miles was running fine.got home shut off.over nite it was damp and after that bikes lights work.go hit start button does nothing.sometimes if bike got wet over night it would...
1-13 of 13 Results
Top