Harley Davidson Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
I have a 03 Duece stalling problem. It will not act up cruising around town when you are working the throttle a lot. You can travel about 10 miles or so at a constant throttle the let off the throttle and pull in the clutch and it will idle down then stall. You can let off the clutch or hit the start button and it will start right back up with no problem. I have checked fuel pressure about 57psi, changed the spark plugs, wires, throttle position sensor, idle air controller. It has set no codes. I NEED HELP!
 

·
Registered
Joined
·
7 Posts
had same problem with 01, took to service and found leakage around intake manifold. Also changed plugs and cleaned carb. Fine now. good luck
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #3 ·
That's my next route. Gonna check around the intake for some leaks with some WD-40. Already changed spark plugs but pulled them back out this morning and it looks kinda strange. One side of the electrode is darker than the other. The darker side is on the intake side. I'm running out of things to check. Trying to avoid paying 120 dollars/hr at the Harley gods.
 

·
Registered
Joined
·
3,517 Posts
Remove air filter and clean the idle air valve. Spray it with carburetor cleaner until all the gunk is cleaned off. Then cycle the ignition on and off a few times to make sure the valve is cycling in and out.
 

·
Retired citizen
Joined
·
24,277 Posts
That sure sounds like a problem with the IAC but the OP states he replaced it along with the TPS.
The TPS should be set to .68v at closed throttle, any less and idle RPM gets lower.
Also I believe there was an injector upgrade for the '03 EFI to 25 degree injectors. Not a recall.
And around '03 -'04 there was an ECM update that addressed driveability issues related to low speed stalling.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #6 ·
You are right. I did clean the IAC at first, but had no change. So I thought maybe it was just wore out, and I just replaced it. Gonna check the TPS voltage again. Checked it before but can not remember what it was. Also gonna get up with the boys at the Harley shop on that other info. Thanks so much for the input. Let you guys know what I find out.
 
1 - 6 of 6 Posts
Top