Harley Davidson Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Howdy all HELP!
I'm new to the Harley world. I bought this AWESOME Bike two weeks ago. Here is my issue. my my helmet headset only the right speaker is working. When I turn on the radio I can hear a little popping sound from the left side like its getting some sort of power but then only the right side is making sound. I plug my headset into the passenger plug and then both sides work just fine... I replaced the Drivers plug wire harness and still it only the right side working!! UGH! Is this normal? is only the right side(for the Driver) that works on Harley audio system??? Other that that I'm love'n this bike!!
 

·
Banned
Joined
·
71 Posts
Howdy all HELP!
I'm new to the Harley world. I bought this AWESOME Bike two weeks ago. Here is my issue. my my helmet headset only the right speaker is working. When I turn on the radio I can hear a little popping sound from the left side like its getting some sort of power but then only the right side is making sound. I plug my headset into the passenger plug and then both sides work just fine... I replaced the Drivers plug wire harness and still it only the right side working!! UGH! Is this normal? is only the right side(for the Driver) that works on Harley audio system??? Other that that I'm love'n this bike!!
Look at the plug, where the harness you replaced, plugs in at . It sounds like one pin is not making good contact . Most likely a ground pin .
 
1 - 3 of 3 Posts
Top