Harley Davidson Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Eddy here, this will be my first post and I’m not too savvy when it comes to motorcycle lingo/talk but im desperate.

My 2007 Softail Standard quit cranking on me after a short ride. I rode it home from the store, parked it in the drive way, shut it off and tried to re-crank to move into garage but nothing happened.

I read some other posts and did the simply things like charge the FOB battery and charge the bike’s battery. I’ll walk you through the fail process of attempting to start my bike:

-I walk up to my bike with my FOB in my pocket (no cell phone near and has fresh battery)

-I turn the ignition switch to ‘Ignition’ and the head light turns on, the neutral light comes on, the little red key figured light on the speedometer comes on and stays on, the oil light warning comes on, and the turn signals come on and stay on (no blinks at all)

*** Note: I don’t hear the familiar sound that happens when I turn the ignition to ‘ignition’… I think it was the fuel pump priming??? Regardless... complete silence.

-I turn the switch to run and attempt to crank the bike by pushing the start button… NOTHING HAPPENS, NOT EVEN A WHISPER OR A SPUTTER!!

PLEASE HELP
 

·
Registered
Joined
·
2,973 Posts
first post go to the new people area and do a proper intro man. it will get you better quicker answers that way . as far as your problem cant help.
 

·
Registered
Joined
·
42,924 Posts
Sounds like your security system is not recognizing your fob.

Double check orientation of battery in fob.
 
1 - 4 of 4 Posts
Top