Harley Davidson Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello Everyone,

New here and am having more issues with my bike.

I have a 09 Fatboy Soft tail. Bike ran fine yesterday. Parked it and when I hopped on this morning it would crank and crank and crank, but no start. Everything sounds like it should pre-start.

It is under warranty, but it is an extended warranty from Harley and they are informing me that if it isn’t covered under the warranty I will have to pay to get the bike there along with labor and parts.

Any Assistance on what this could be and if it most likely covered under warranty would be great.

I have not checked the air cleaner or anything else as I had to get to work and caught a ride from a fellow Soldier who lives in the same building as me.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Will check the codes as soon as i get home... Thanks for the info on how to check the codes. helps if I read the whole thread before reposting.
 

·
Registered
Joined
·
11,968 Posts
Can you hear the fuel pump pressure up?

My son is stationed in ARMY there. Pm me if you want, may know each other.
 

·
Señor Member
Joined
·
19,667 Posts
Start with the basics, spidey.

Does it have fuel? Is it getting it?

Does it have air? Is it getting it?

Does it have spark?

Good luck.
 

·
12roadking
Joined
·
118 Posts
check if check engine light is on with ignition on,was having same issue but very intermittently ended up being the ignition switch,would turn ignition on and off till engine light was on, bike would fire right up.
 
1 - 6 of 6 Posts
Top