Harley Davidson Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys I have a 2009 Street Bob that won’t start. Drove it across the street to the gas station. Filled up and bike wouldn’t restart. Turn the key on and can hear the fuel pump prime but when hitting the start button nothing, not even a click then the flashers flash left/ right/ left/ right/ left/ right and stops. Red key light stays on but that’s been on since the the LED front/ rear signals were replaced which was a year ago. If I switch to RUN the red light comes on and stays on, turn switch to off the red key light goes off.

I tried both key fobs with new batteries, replaced the main battery and still same issue. I can make it start by turning key to the RUN position and applying power directly to the starter using my power prob but after 3 seconds it shuts off. Checked all fuses and grounds. Don’t have the code for the alarm bypass so can’t try that. I did try the most common codes that I’ve found on the forum with no luck. Don’t know how to verify if something like the alarm antenna or modules are not working or failed. Weird how it ran fine, turned it off, filled up with gas and now this. Any ideas? Suggestions? All will be appreciated!!
 

·
CRSO
Joined
·
348 Posts
The alternating lights tell me it’s the security system likely disabling the bike…

Provided the batteries in the fobs are good (AND installed the correct way, not upside down), you’ll need to enter the PIN with the turn signals.

The button sequence for doing this is in the riders manual…or you can look it up on YouTube.

If you’ve had this bike since new (or the original owner never changed it) try all 1’s (11111); Harley has also used ‘31313’ and some came from the factory with the code set to the last 5 numbers of the bike’s VIN. Try all those…

If any of those work then decide on personal PIN code, change it and WRITE IT DOWN!

Good luck & ride safe!


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I took the bike into Harley and they verified that the TSSM has failed. Both the replacement part and the TSSM without the security built in is on back order. Harley is pretty steep on the labor! 1hr to install the non security TSSM and 1.5hr with the security (1hr install and .5ht for programming). The TSSM from start to finish takes about 10 minutes to pull out and put in. I found a new security equipped TSSM on a different Harley site I’m going to buy, take it up there, swap it out myself and pay the .5hr labor to program it and save myself the $118! Also think they went a little overboard on the front brake quote!
Font Parallel Rectangle Number Screenshot
 

·
Registered
Joined
·
4 Posts
Hey guys I have a 2009 Street Bob that won’t start. Drove it across the street to the gas station. Filled up and bike wouldn’t restart. Turn the key on and can hear the fuel pump prime but when hitting the start button nothing, not even a click then the flashers flash left/ right/ left/ right/ left/ right and stops. Red key light stays on but that’s been on since the the LED front/ rear signals were replaced which was a year ago. If I switch to RUN the red light comes on and stays on, turn switch to off the red key light goes off.

I tried both key fobs with new batteries, replaced the main battery and still same issue. I can make it start by turning key to the RUN position and applying power directly to the starter using my power prob but after 3 seconds it shuts off. Checked all fuses and grounds. Don’t have the code for the alarm bypass so can’t try that. I did try the most common codes that I’ve found on the forum with no luck. Don’t know how to verify if something like the alarm antenna or modules are not working or failed. Weird how it ran fine, turned it off, filled up with gas and now this. Any ideas? Suggestions? All will be appreciated!!
I had this same problem a month ago. After a LOT of homework and a Harley mechanic friend's input I replaced the "Turn Signal Module" commonly called a TSSM p/n 68299-00B. This is a totally enclosed plastic item (about fist size) sitting near the main fuse panel and it simply snaps in and out after disconnecting/connecting a electrical plug. That said, my bike is a 2003 FXLR and Harley uses this device as a turn signal control AND a security system brain. The fly-in-the-soup is that Harley combines the two functions in some years/models and in others the security part is not part of it. I found a used one that did both on eBay for $89.00 and took a chance on it working. It did and the bike immediately started and run. I think a TSSM has the combination of controls and a TSM just the turn signals. This is still a semi-lucky fix in my mind but explore it some and you may have a TSSM like I did. If you only have a TSM, then I guess it might not help a bit. My electrical schematics called out a TSSM so check your service manual to maybe help settle the question.
Torque
 

·
Registered
Joined
·
4 Posts
I took the bike into Harley and they verified that the TSSM has failed. Both the replacement part and the TSSM without the security built in is on back order. Harley is pretty steep on the labor! 1hr to install the non security TSSM and 1.5hr with the security (1hr install and .5ht for programming). The TSSM from start to finish takes about 10 minutes to pull out and put in. I found a new security equipped TSSM on a different Harley site I’m going to buy, take it up there, swap it out myself and pay the .5hr labor to program it and save myself the $118! Also think they went a little overboard on the front brake quote! View attachment 799917
Gotta love all Harley shop's labor rates and times. Don't feel like the Lone Ranger out there. Lost of owners that think the same thing.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
I had this same problem a month ago. After a LOT of homework and a Harley mechanic friend's input I replaced the "Turn Signal Module" commonly called a TSSM p/n 68299-00B. This is a totally enclosed plastic item (about fist size) sitting near the main fuse panel and it simply snaps in and out after disconnecting/connecting a electrical plug. That said, my bike is a 2003 FXLR and Harley uses this device as a turn signal control AND a security system brain. The fly-in-the-soup is that Harley combines the two functions in some years/models and in others the security part is not part of it. I found a used one that did both on eBay for $89.00 and took a chance on it working. It did and the bike immediately started and run. I think a TSSM has the combination of controls and a TSM just the turn signals. This is still a semi-lucky fix in my mind but explore it some and you may have a TSSM like I did. If you only have a TSM, then I guess it might not help a bit. My electrical schematics called out a TSSM so check your service manual to maybe help settle the question.
Torque
Yes I’ve done lots of research and know exactly where it is and what it does. I’ve taken it out more than once making sure the pins on the connection was good. They do offer 2 options. 1 is with the security system using the key fobs or the other is just a regular TSSM without security and this option is just a “plug and play” no programming needed.
 
1 - 6 of 6 Posts
Top