Harley Davidson Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
314 Posts
Discussion Starter #1
I have an 09 Streetglide, and have noticed that sometimes when going over a bump or small hole in the road, the radio will go out for a few seconds, then come back on. Is this normal? It's very similar to what a single laser CD player will do when your car hits a bump. I've never seen it with the FM radio, though. I'm guessing something is loose with the ground or something like that. Anyone else have this problem with their Glide? Thanks :)
 

·
Shovelhead
Joined
·
391 Posts
I've haven't had a problem yet @ 4500 miles. as you said something may be loose?
 

·
Registered
Joined
·
89 Posts
I am not sure about mine, I have never used it. I like the clock, but they could have kept the radio.
 

·
MPG'S? Who gives a
Joined
·
9,925 Posts
never had that happen on mine.As mentioned sounds like a loose connection.
 

·
Old Member
Joined
·
2,896 Posts
Totally not normal, my 09 has the CD cut in and out sometimes and I'm waiting for it to get worse so I can take it in for warranty.
 

·
I {Heart} Hookers.
Joined
·
31,321 Posts
I have an 09 Streetglide, and have noticed that sometimes when going over a bump or small hole in the road, the radio will go out for a few seconds, then come back on. Is this normal?
Not normal.

Take it back.

Warranty.

Loose connection.
 

·
Registered
Joined
·
314 Posts
Discussion Starter #7
Yea that's what I was thinking. I was waiting for the 1000 mile service and get it taken care of then as well as get some stuff put on it. I rode it today and every bump I hit, the radio went off. I'm sure it's nothing major, just a loose connection. At least I'm hoping. Thanks again.
 

·
Registered
Joined
·
54 Posts
not normal have them check it out , thats all you would need is to have a short in a wire that would ground out ....yikes!!!
 

·
"Riding for Tim" RIP
Joined
·
607 Posts
I have an '08 Street Glide that I have put 20,768 miles on in just over a year. I am starting to have radio problems also; the sound will go out (radio or CD) every thing functions as normall just no sound and I have to turn the power off and back on to get the sound back. The problem does not seem to be a connection issue because it will do it on the side stand. At times it will play for 30-40 minutes with no problem and other times it will act up a number of times in 10-20 minutes. I am scheduled for check out next Thursday, the service rep said something about flashing the bike to make sure it has the latest updates?
 

·
Boooya!!!
Joined
·
2,767 Posts
does the radio display go out when that happens? if so check all power connections even battery and gnd. if the display stays on and the sound goes out on all speakers. there is a short at one of the speaker leads to ground that shuts off the amp in the radio. also do you have the harley amp under the tour pack? check its connections under the seat.
 

·
Registered
Joined
·
314 Posts
Discussion Starter #11
No actually, the screen goes out as well. It only does it sometimes, usually when I hit a big bump. Then the screen will go out and the music will stop for about 2-3 seconds, then pop back on like nothing ever happened. I'm thinking it might be something internally in the radio itself. Maybe I just shouldn't play it until I get it looked at.
 

·
"Riding for Tim" RIP
Joined
·
607 Posts
Well, took mine to the shop and they downloaded the latest software into the stereo, and test drove her about 40 miles with no problem. I left the shop and the radio stoped making sound twice on my way home (30) miles. Called the dealership and they are ordering me a new radio.
 

·
Registered
Joined
·
314 Posts
Discussion Starter #13
yea, I've heard the radios on the bikes aren't the best. But I suspect mine is a loose plug or wire since no other gauges or anything went out. Mine just completely shuts off after hitting a bump then comes back on like nothing ever happened. They might need to order me one, too. I'll find out soon enough. Thanks.
 

·
Registered
Joined
·
58 Posts
I have an '08 Street Glide that I have put 20,768 miles on in just over a year. I am starting to have radio problems also; the sound will go out (radio or CD) every thing functions as normall just no sound and I have to turn the power off and back on to get the sound back. The problem does not seem to be a connection issue because it will do it on the side stand. At times it will play for 30-40 minutes with no problem and other times it will act up a number of times in 10-20 minutes. I am scheduled for check out next Thursday, the service rep said something about flashing the bike to make sure it has the latest updates?
For HK radio problems, check with a HK tech at:

http://www.justanswer.com/electroni...212-2&JPRC=1&gclid=CKjnt_aL25oCFR4hnAodFFDl3g
 

·
Boooya!!!
Joined
·
2,767 Posts
I have seen the problem four times in the last 4 months. seems to be something in the 09 HK radio. amp goes out. the 4 i dealt with we add amps to and originally thought it was the aftermarket stuff. then took one of the radios out and sent in found a problem in the radio itself. Check with the techs at your local harley dealer. see if they have any briefs on the problem.
 

·
Registered
Joined
·
314 Posts
Discussion Starter #16
yea as it turned out, it was a loose ground or a couple of them. It's fixed now. Got it back the morning of Rolling Thunder. Thanks for all the help. Ride safe out there.
 

·
Registered
Joined
·
314 Posts
Discussion Starter #19
They don't put new radio's back into your bike, there Refurbished units
Are you kidding me?!!!! That's bullsh*t. Your bike is under warranty for 2 years, and parts should be replaced by new parts. I mean, it's not like you didn't throw down about $20 grand for two wheels, you know? :mad:
 

·
Road gliding man
Joined
·
61 Posts
It’s a waste of time, been down that path 3 times so far.
H-D wants to keep using up the refurbish units until the maker gets there crap worked thru. the system. By that time you’ll have the radio that I owned when bought my bike.
:mad:
 
1 - 20 of 22 Posts
Top