Harley Davidson Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I just bought my first Harley last week, a 15 road glide so far I love it. Got it home and put it in the garage and see the light behind the mileage display is on only the light at the end of the display also. Any ideas on what the issues may be? Thanks for any help I have no clue seeing as it's all new to me.
 

·
Registered
Joined
·
945 Posts
That Odometer light will come on any time the "trip" button is touched (The button on the left grip , kinda looks like a sprocket or a gear) It doesn't need the key on for power. It should turn itself off in 30 seconds or so.
Welcome to Harley's and the forum! from SoCal.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
That Odometer light will come on any time the "trip" button is touched (The button on the left grip , kinda looks like a sprocket or a gear) It doesn't need the key on for power. It should turn itself off in 30 seconds or so.
Welcome to Harley's and the forum! from SoCal.
It doesn't turn off, I can go out to the garage the next morning and it's still on
 

·
Registered
Joined
·
945 Posts
It doesn't turn off, I can go out to the garage the next morning and it's still on
Fiddle with that button on the left grip. It could be stuck or broken.. i would try propping the switch up with something like a tissue or q-tip (gently) then wait a minute or so to see if the lamp goes out.
If you purchased it from a dealership, tell them about it, they should fix it at no charge!
 

·
Registered
Joined
·
945 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #9
The switch works perfectly on the left bar turns on odometer then goes out after a little. Here is a picture of what it looks like
785131
 

·
Retired citizen
Joined
·
23,115 Posts
That kinda looks like the light has a short to B+. The light wire is shorting to a wire that's usually hot (B+).
 

·
Veteran
Joined
·
28 Posts
I just bought my first Harley last week, a 15 road glide so far I love it. Got it home and put it in the garage and see the light behind the mileage display is on only the light at the end of the display also. Any ideas on what the issues may be? Thanks for any help I have no clue seeing as it's all new to me.
I checked with my Harley mechanic and he said that was a common problem and either the trip switch or the housing has to be replaced.
 

·
Registered
Joined
·
31 Posts
I ride a '15 Road Glide Special that I bought new, and I love it, too. Sorry I can't help you with that switch problem. I've never had that happen. Safe riding!
 

·
Registered
Joined
·
15 Posts
Welcome I'm a 16 roadglide guy myself haven't had that problem but my bike wouldn't start in gear for a while I just fiddled with the clutch lever a few times and it started working so try just messing with that button tap on it lightly a few times you may get lucky
 

·
Registered
Joined
·
5 Posts
Discussion Starter #14
I checked with my Harley mechanic and he said that was a common problem and either the trip switch or the housing has to be replaced.
I've messed with a little with no luck looked for a bare wire underneath the gauges and found nothing. Does you mechanic buddy mean the gauge housing?
 
1 - 14 of 14 Posts
Top