Harley Davidson Forums banner

1 - 11 of 11 Posts

·
CVO Captain
Joined
·
742 Posts
Discussion Starter #1
I was looking around couldn't find it on the forum. I have a 2015 CVO limited I took it out today for a ride and notice it was idling at 2,000 rpm. I though maybe the motor was really cold. After a few minutes it still stayed at 2,000 rpm. I took for a ride thinking it will go back to normal. Every time I stop and switch in to neutral it would jump up to 2,000 rpm. My throttle has free play it's not stuck in open when I roll the throttle forward the idle drops to normal. Any suggestions or help.
 

·
I {Heart} Hookers.
Joined
·
31,321 Posts
Reset the TPS.

Turn ignition switch on for 10 seconds, then off for 10 seconds (Don't start engine).

Repeat a total of 4 times.

DO NOT TOUCH throttle while doing it.
 

·
Registered
Joined
·
23,035 Posts
If the throttle is open when starting on a throttle by wire bikes, it fools the sensor to think "this is the closed throttle position" and will idle fast. Shut off the bike and start it , just make sure you do not twist the throttle.

I found this out after years of riding a carbed evo and switching to a FI TBW twin cam.
 

·
CVO Captain
Joined
·
742 Posts
Discussion Starter #4
Reset the TPS.

Turn ignition switch on for 10 seconds, then off for 10 seconds (Don't start engine).

Repeat a total of 4 times.

DO NOT TOUCH throttle while doing it.
After the 4th time I start it up
 

·
CVO Captain
Joined
·
742 Posts
Discussion Starter #5
@Dave63 it work thank you for that. Bike is revving at normal rpm now. @candyman1340 I try shutting it off and on a few times it didn't work and my hands where off the bike.
 

·
Vanilla Gorilla
Joined
·
1,384 Posts
This can also happen if you hit the kill switch while the bike is at higher RPM's.
 

·
Registered
Joined
·
563 Posts
This issue can happen on any EFI bike if the throttle is open when the ignition is turned on. It will fool the ECM into thinking its the the closed throttle position like candyman1340 mentioned. It's not just TBW bikes but all EFI machines.
 

·
Registered
Joined
·
4 Posts
I had the same symptoms and this solution worked for me today. Thanks for the tip.
 
1 - 11 of 11 Posts
Top