Harley Davidson Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
having problems with the EFI system, being told that year with the intake that was put on that year I guess up to 2002 were all having problems. Keeps fouling out the plugs, had a power booster put on it did great for one summer but right back to same thing. stays in the garage. don't want to sale it but don't want the headache every time I ride. 2000 FLT 34k on the motor had 202 cams put in it, checked for intake leaks. need help what I can do with out breaking the bank.
 

·
Retired citizen
Joined
·
24,285 Posts
What "power booster" ?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
just called the shop that put it on well get back to you, its been a couple of since I had it put on cant fine the info on it
 

·
Retired citizen
Joined
·
24,285 Posts
Well if it's a Power Commander III that could be the root of the problem. They have a bad history.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
that would be my luck, didn't have problems with the bike until I got back from Sturgis couple of years back. Bike ran great then just like that start to foul the plugs
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
that's what it is a PC3 and now he tells me doesn't work on them anymore there went 500 out the window. he now wants to sale me a race tuner for 600 yea ok!!!
 

·
Banned
Joined
·
71 Posts
that's what it is a PC3 and now he tells me doesn't work on them anymore there went 500 out the window. he now wants to sale me a race tuner for 600 yea ok!!!
Unplug the PowerCommander and see how the motor runs without it .
If it runs OK, then your problem is with the PowerCommander . If it runs the same, then problem is elsewhere .

IMO PowerCommanders are no better or no worse than other tuners on the market . All of them have had their problems from time to time .



:biker:
 

·
Indecisive Member
Joined
·
292 Posts
If the problem lies with your pc3 I would look into a pcv/pc5 or fuel pak from fuel moto
 

·
Registered
Joined
·
5 Posts
get rid of the power commander first you have a magnelli marelli injection system (probably spelled that wrong) what you need is a hot and cold idle reset very common with that set up after that is done you can probably plug the power comander back in so your money isnt a waist all though I wouldn't scince it basically intercepts all the sensor info and changes it before the ecm gets is
 
1 - 10 of 10 Posts
Top