Harley Davidson Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have Rush slip on's on my bike. The air being emitted from the right side exhaust (front cylinder) is warmer and stronger than the exhaust air being emitted from the left exhaust (rear cylinder). The right (front) slip on portion of the exhaust is much warmer to the touch than the left side (rear cylinder). I noticed in the left (rear) slipon a little wetness (black and oily) at the bottom rear of same. The bike seems to be running ok. Both spark plugs appear to have the same color with respect to firing. Neither plug is oily. The light for start up comes on before starting as usual then goes off after fuel pump is primed and then comes back on for a few seconds, goes off and doesn't come on again until the ignition is turned on again as usual.
 

·
SNAFU organizer
Joined
·
4,127 Posts
Cause your rear cylinder exhaust has a Y pipe that goes to both
sides. your left side slip on is only doing about a 1/4-1/3 the work the right side is. unless you got true duals you aint telling us about.

Pleas stop by the "new members" header and introduce yourself
 

·
Registered
Joined
·
8 Posts
If your "check Eng" light comes on then goes out then comes on again and then goes out again...(whew hope that came out right) you are storing a fault code. May be nothing to do with your pipe concerns as I agree it's in the header design and the norm. May want to have it "read" at the dealer or with a TwinScan or go through the activation procedure on the bike. You'll find direction to do that on the forum.
 

·
SNAFU organizer
Joined
·
4,127 Posts
If your "check Eng" light comes on then goes out then comes on again and then goes out again...(whew hope that came out right) you are storing a fault code. May be nothing to do with your pipe concerns as I agree it's in the header design and the norm. May want to have it "read" at the dealer or with a TwinScan or go through the activation procedure on the bike. You'll find direction to do that on the forum.
Yea possible the light will stay on for about ten seconds if you have fault but it may dip for a second when you first start it as the pump catches up again.
 
1 - 5 of 5 Posts
Top