Harley Davidson Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello--I just purchased a new Electraglide standard and am having intermittent problems with the bike idling too high. Sometimes after the bike has sat overnight, I start it for the first time that day. The idle jumps from 2000-2500 rpm and will sit there. Other times with a warmed up engine, I will restart it and the idle sits at around 1500 rpm. I have had the bike a little over a week and this has occurred about 6 times. I took it to a local dealer and they said it was the engine idle temp. management system (parade mode). They said I had it set on. I wasn't aware of the eitm system until then. I had my doubts but the bike ran perfect when I got there. Otherwise the bike runs great. Anyone out there have a suggestion of the problem? Also, the problem usually goes away after I shut the bike off and restart it . Sometimes. Or I ride it for a while. Thanks.
 

·
Just passing thru
Joined
·
6,636 Posts
I was going to say you might have a sticking throttle cable but I dont think your bike even has cables. Fly by wire system. Any sensor problems will show up as an engine light. then you could retreive the code to see what the problem is.
 

·
2007 Ultra Classic
Joined
·
1,285 Posts
Stick around and watch it closely.

The fix is supposed to be available to the Stealers this week.

There have been several accidents when downshifting and the "throttle sticks".

Jack Hammer, the Bandido Dallas area Pres was killed when his did it.

I have seen several in this area with the sticking problem.
 

·
Registered
Joined
·
212 Posts
Stick around and watch it closely.

The fix is supposed to be available to the Stealers this week.

There have been several accidents when downshifting and the "throttle sticks".

Jack Hammer, the Bandido Dallas area Pres was killed when his did it.

I have seen several in this area with the sticking problem.
I feel warm and fuzzy reading that post, DNM.......freaking SCARY.
 

·
Registered
Joined
·
2 Posts
One reason for the temporary high idle is on a 08 with fly by wire throttle, when you are coming up to a stop and you pull in the clutch, DON'T return the throttle past the zero point, which if you do for a while it can mess with the computer on the idle position. Don't panic as it will return to normal after a while or shut the bike off for a few minutes and it should be back to normal. If it is revving to high at a stop sign you have to take it past zero to bring it back down. As soon as you can stop and turn the bike off for a few minutes and then restart. Everything should be back to normal.
I am not sure why it does it at first startup though. And HD is working on fixing this.
 

·
Registered
Joined
·
212 Posts
The real fix for high idle o n DBW bikes is to cycle the ignition switch on for a few seconds then off for a few seconds four times then it will idle at 1k until you turn the bike off with the throttle in any other position then rest.
 

·
Registered
Joined
·
2 Posts
I need advice on 2008 e glide, just got it, less than 300 miles, and the throttle seems to idle high, just started last nite, any advice.
 

·
Registered
Joined
·
2 Posts
TY diamond, livin in the DC area, this is my 3rd HD, 02,06, and 08, and a hnda trike in between the 02 and 06. This seems like a great site/forum if your having an mechanical probs. etc. thanks again
 

·
Registered
Joined
·
1 Posts
2008 engine idle problem

What was the fix here? I have the same problem. Starts around 2200 rpm. intermittent. Sounds and runs terrible at this high idle rate.
 

·
Retired citizen
Joined
·
23,371 Posts
The real fix for high idle o n DBW bikes is to cycle the ignition switch on for a few seconds then off for a few seconds four times then it will idle at 1k until you turn the bike off with the throttle in any other position then rest.
On and off four times resets the throttle . Dealerships have an ecm download that addresses this issue .
 

·
Registered
Joined
·
4 Posts
I have an early model 2007 HD Electra Glide w/ 7,400 mi. Recently the engine has developed a very bad miss or momentarily cuts out. While the engine is running poorly, cutting out & acting like it is out of gas, the service fuel light will come on but gas tank is full. Then the service fuel light will go out & the motor will run better but not quite normal. It appears the service fuel light not only monitors the fuel in the gas tank but also the fuel pressure to the ejectors?

I called the dealer & he has not heard of a similar problem on 2007 touring models & suggested a possible fuel pump replacement at an estimated cost of $250 for the part.

Has anyone else experienced a similar problem on a 2007 HD touring model? Does anyone have any suggesting of what could possible cause this type of problem? The bike is out of warranty & the local HD dealer hr/ rate is $80/ hr.

Thanks in advance for helping!
Andy
 

·
Retired citizen
Joined
·
23,371 Posts
The real fix for high idle o n DBW bikes is to cycle the ignition switch on for a few seconds then off for a few seconds four times then it will idle at 1k until you turn the bike off with the throttle in any other position then rest.
Yes ... and there is a fix for this at the HD shop , a new flash for the ecm . Has to be installed with the Digital Tech .
 
1 - 17 of 17 Posts
Top