Harley Davidson Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
2008 has the internal fuel pressure regulator, is it supposed to spay fuel out the top, bike will start and idle but will die as soon as you hit the throttle will not start back up till next day and same thing any ideals
 

·
Just Ride
Joined
·
3,204 Posts
Filter or pump going bad. Could be a hole in the internal hose. You didn't mention how much fuel in tank. Now go to new members section and properly introduce yourself, need to know if you can fix it if we tell you how.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Tank is full filter is a couple months old, looks clean. Is it normal for gas to spray out of the top of the regulator
 

·
Retired citizen
Joined
·
23,201 Posts
Tank is full filter is a couple months old, looks clean. Is it normal for gas to spray out of the top of the regulator
Yes, that's the pressure bypass. Pump reaches 55 PSI and excess fuel is returned into the tank.
If you're still having fuel delivery problems you should have the pump pressure tested. Requires some specialised test equipment.
 

·
Retired citizen
Joined
·
23,201 Posts
Also I'm not sure what you mean about fuel spraying out of the top of the regulator. There's an o-ring on the regulator where it plugs into the socket, fuel shouldn't be spraying from that. That could cause a drop in fuel pump pressure.
 
  • Like
Reactions: Pred8er

·
Registered
Joined
·
9 Posts
Discussion Starter #8
There is a small hole in thefilter houseing where fhe regulator seats is that the return, this is where the fuel is spraying. Just asking if this is normal
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
Up date my roadglide ,i unhooked the line from the tank and put it back on, was told they sometimes vapor lock, apparently it was bike started and have been ring around for an hour stopping turned ir off a few times and started back up, the engine light is on now and smells like its running rich , but runs good. Could this be a regulator issue?
 

·
Retired citizen
Joined
·
23,201 Posts
Up date my roadglide ,i unhooked the line from the tank and put it back on, was told they sometimes vapor lock, apparently it was bike started and have been ring around for an hour stopping turned ir off a few times and started back up, the engine light is on now and smells like its running rich , but runs good. Could this be a regulator issue?
Just an FYI, anytime I tear into an EFI tank to change the fuel filter I replace the regulator too. It's got the same miles on it as does the filter.
 

·
Retired citizen
Joined
·
23,201 Posts
Sir ? I ain't no sir I'm just a non-com !;)
 
  • Like
Reactions: WiSeNhEiMeR
1 - 12 of 12 Posts
Top