Harley Davidson Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I recently bought a 1340cc harley and its in a streetbob style. I have a few issues. First when i go to start the bike it can start with the engine switch off, i followed the wires and theyre still good, is that a normal issue with harleys? Ive owned quite a few dirt bikes but this is my first harley. Second, when i first bought it was starting fine till it wasnt...only way it would start is by jumping then when i took it for a cruise it would shut off. I took out the solenoid and cleaned it. Bought a new battery and worked for a day, sat overnight and samething was happening. Could it be the starter?
 

·
Just Ride
Joined
·
3,267 Posts
Charging system is bad, got a manual?
 

·
Registered
Joined
·
565 Posts
The start switch gets its 12 volts from the run switch. Either the run switch is bad or there is a wiring failure feeding the start switch the 12 volts.
 

·
Registered
Joined
·
566 Posts
Check the battery cables at both ends- this includes the ground. It probably has nothing to do with the run switch but may be the cause of the bike cutting out.
Don't buy a starter, or anything else, until you diagnose the issue.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Check the battery cables at both ends- this includes the ground. It probably has nothing to do with the run switch but may be the cause of the bike cutting out.
Don't buy a starter, or anything else, until you diagnose the issue.
The cables are good. I changed my ground wire and the relay ground. I just ordered a multimeter from amazon and gonna test the battery and the stator.
 

·
Registered
Joined
·
5,025 Posts
Dyna's have two ground points. Neg. cable from battery to frame lug, then lug to primary case. The lug can be corroded or loose.
 
1 - 7 of 7 Posts
Top