Harley Davidson Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2009 FLSTF FatBoy with 14,000 miles, when starting with a cold engine 99% of the time it starts fine, but if the engine is hot, say you been on a ride and stop to fuel up, when starting a hot engine it makes a terrible sound like something slams real hard inside the engine, it starts ok but it makes a hard noise (hard to explain unless you heard it yourself) and sometimes it kicks back real hard. This is mostly with a hot engine, a warm or cold engine it hardly ever does it. Any ideas? I appreciate your help. Thanks...
 

·
Registered
Joined
·
12,739 Posts
Does it spit back thru air cleaner? Any strange noises from the primary, rattle at idle? IF you have the stock from factory compensator, it might be dying. Replaced mine with a upgraded Screaming Eagle one, think 2011? no more issues with kick back.
 

·
Registered
Joined
·
1 Posts
I have a 2009 FLSTF FatBoy with 14,000 miles, when starting with a cold engine 99% of the time it starts fine, but if the engine is hot, say you been on a ride and stop to fuel up, when starting a hot engine it makes a terrible sound like something slams real hard inside the engine, it starts ok but it makes a hard noise (hard to explain unless you heard it yourself) and sometimes it kicks back real hard. This is mostly with a hot engine, a warm or cold engine it hardly ever does it. Any ideas? I appreciate your help. Thanks...

What did you finally figure out about your issue?

BuddyK
 

·
Registered
Joined
·
1,459 Posts
What did you finally figure out about your issue?

BuddyK
The original poster is a one hit wonder who never followed up on his issue, two years ago...

If you want some help, start a new thread, give the details of the issue and the model and year bike.
 
1 - 8 of 8 Posts
Top