Harley Davidson Forums banner

1 - 20 of 21 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Have a 2015 dyna street bob. Set ignition switch to on, lights work, set the run switch and fuel pump primes, upon hitting the start switch to crank bike the fuel pump then primes again and keeps priming while hitting or even holding the switch. Any help would be appreciated
 

·
Retired citizen
Joined
·
22,934 Posts
The fuel pump should only prime once for 3 seconds then shut off until the engine starts.
A fuel pump pressure test will determine if there's a loss of pressure causing the pump to continue priming. There might be a plugged fuel filter or a hole in the pump to filter hose which is common. Fuel filter replacement is at the 25K service interval.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
I will look and inspect after work today I’m at about 22k miles on the bike I appreciate the help ??
 

·
Retired citizen
Joined
·
22,934 Posts
Yep, that's the pump overflow from the regulator. Do you see any fuel spraying from holes in any of the hoses ?
You've got it that far apart so good time to replace the filter and regulator, less than $50.00.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #6
The fuel filter is excessively dirty, dirt and debri came out as well. I will replace the filter and regulator today, and give you feedback. I really appreciate the help. Thank you
 

·
Registered
Joined
·
11,522 Posts
:popcorn
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
Installed the new fuel filter, and pressure regulator the bike is still only priming upon trying to start.
 

·
Retired citizen
Joined
·
22,934 Posts
It's supposed to prime once for 3 seconds then run when the engine starts. If you happen to remove your finger from the start button then the pump will prime again.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #12
Bike just primes never cranks doesn’t even try to start. Pressing or holding the start switch just sends it back into a fuel pump prime
 

·
Retired citizen
Joined
·
22,934 Posts
Bike just primes never cranks doesn’t even try to start. Pressing or holding the start switch just sends it back into a fuel pump prime
Whoa, are you saying the engine doesn't even turn over? Starter doesn't spin up? Then that doesn't sound like a fuel delivery problem at all.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #14
Correct it’s almost like the starter isn’t getting any power for some reason, I have checked that. The bike is stuck at my ex wife’s house so it’s hard to get to. Any ideas?
 

·
Just Ride
Joined
·
3,120 Posts
Pull main fuse for reset.
 

·
Retired citizen
Joined
·
22,934 Posts
I would check all the battery cables and the ground wire at the starter bolt. Make sure the battery is fully charged, 12.8v >.
You can use a jumper wire from the battery positive terminal to the connector on top of the starter (unplug green wire) to spin the starter up to verify it works. With the ignition on the engine should start. Ignition off or on the starter should spin up with the jumper.
 
1 - 20 of 21 Posts
Top