Harley Davidson Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi All,

Potentially stupid question: I just bought a new 2020 Road Glide Limited, she's a beauty. But while the infotainment system is lit up and working perfectly, the gauges (speedo, tach, fuel, and volts) though working, are not lighted. I went through a tunnel and noticed that they disappeared, no lights at all.

Is something wrong, or is there a knob or control somewhere that controls the those lights?

Thanks!
-Paul
 

·
Just Ride
Joined
·
3,162 Posts
Take it back, it's under warranty.
 
  • Like
Reactions: Smoketown$1

·
Registered
Joined
·
845 Posts
Two-Year warranty . . . let the dealership take a look at it.
 

·
Roadie Rider
Joined
·
17 Posts
Should be lit. No adjustment control for the lights in the guages. Sounds like a fuse or wiring issue. Trip to the dealer is in order.
 

·
Registered
Joined
·
7,148 Posts
Paul.
Have you checked your manual?
On my 14 I can change the background color and the brightness


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Paul.
Have you checked your manual?
On my 14 I can change the background color and the brightness


Sent from my iPhone using Tapatalk
I did look at the manual, but any references to adjusting color or brightness was for the infotainment screen. But I took a ride this evening and the gauges were lit up. So there must be a sensor that turns them down or off in the daylight. In any event, everything is working.

Thanks for the replies.
-Paul
 

·
Retired citizen
Joined
·
23,115 Posts
My car does the same thing. If the outside lighting level changes suddenly it takes a while for the gauge lighting to catch up.
 
1 - 9 of 9 Posts
Top