Harley Davidson Forums banner
1 - 12 of 12 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi guys I've got a 95 dyna convertible that I got in November it ran great in November but when I got it back out in April it started running lean since it had sat for 17 years I cleaned the carb and ever since then it has been running pig rich. I used a piece of wire to clean the Jets and lots of carb cleaner and compressed air to make sure everything was nice and clean. I should also mention it's a mikuni carb.

I have since been chasing my tail trying to figure out what is going on with it I have dropped the main jet several sizes changed the needle to the #97 leanest needle offered and the idle jet is the smallest mikuni makes. It still is too rich it will foul the plugs out if I run below 2500 rpms. It is fine at highway speeds but still eventually fouls the plugs after about 100 miles. I'm not sure what is wrong with it and need advice

So far I have replaced the choke cable with mikuni's adjustable cable checked intake seals replaced the tank screen and fuel line and replaced the vacuum line from manifold to fuel valve. My next plan is to replace the screaming eagle ignition module with a dynatech 2000 and add dual coils but it's 400 bucks and I want to make sure I'm not overlooking anything
 

·
Just Ride
Joined
·
3,767 Posts
Sure it's gas fouled? Might be time for a top end
 

·
Registered
Joined
·
5,310 Posts
Sounds like the enrichener system is clogged/plugged. Does it run differently when the enrich/choke cable is pulled out?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
it fouls the plugs quicker and bumps the idle up when i pull it out right now if i pull it out the bike won't start but it starts easily with clean plugs and not using the enrichener
 

·
Poser Member # 99
Joined
·
18,148 Posts
Sounds like you need to take carb off and take apart again and let it soak in carb cleaner for a couple of days . try Gumout liquid carb cleaner to soak it in . Then blow every thing back out and put it back like it was when you started . then see what you have
 

·
Retired citizen
Joined
·
24,290 Posts
If the vacuum slide isn't functioning correctly a rich condition occurs because there's less air going through the venturi with almost the same amount of fuel going through the jets.
I would check that the slide isn't leaking vacuum.
 

·
Retired citizen
Joined
·
24,290 Posts
What, his Mikuni doesn't have a vacuum slide ? What model Mikuni does the OP have ?
 

·
Retired citizen
Joined
·
24,290 Posts
Well I guess I could be wrong, I always thought the Mikuni had vacuum assist on the slide but I was just eyeballing an exploded view of the HSR42 and it appears to be totally manual. It looks like the cable pulls a lever on the slide shaft which rolls the slide up and down.
Learn something new every day !
 

·
Registered
Joined
·
5,310 Posts
Yep, the Mikuni HSR's are flat slide, no vac. assist. The slides rattle a bit at idle, but it's not terrible.
 
1 - 12 of 12 Posts
Top