Harley Davidson Forums banner

1 - 20 of 31 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
Help!! Ok so I bought a nice 98 Electra glide, and the speedometer is broken so it free spins and none of the gauges work, no horn to turn signals, as soon as you put a new fuse in it blows instantly, there are new speakers and a new radio there were fun signals at the bottom that I sniped out they were beat up, I’ve looked for a rubed wire but nothing that I can find, any help will be appreciated!
 

·
Registered
Joined
·
1,507 Posts
It could be a dozen things. Usual techniques for troubleshooting shorts should work. A few things have me curious. What are fun signals and at the bottom of what?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
It was a auto correct, turn signals... they were aftermarket and had curb rash and broken lenses, thank you for the reply
 

·
Registered
Joined
·
1,507 Posts
After market means somebody was playing. No telling what other people do, might be a clue as to someplace to start.
 

·
Retired citizen
Joined
·
22,529 Posts
OP currently has 2 threads going for the same issue. Maybe mods can meld them if they still have the power !
 

·
Registered
Joined
·
26 Posts
Discussion Starter #6
I appreciate the help, I know this is a pretty common problem when people do work themselves when they probably shouldn’t, I know all the steps to find a short. This just has me stumped, as soon as I turn it to on it pops it. Just figured I would ask you guys, I appreciate the help and advice, I’m new to the page so if I posted it in the wrong spot I apologize,
I’m getting a key cut today so I can pull the Ignition and inner fairing so I can inspect those wires. I’ve seen a few rubbed wires by the radio but they are not touching anything so I tape it, it’s a little messy I need to go through sit and figure out what’s needed and what’s not,
 

·
Retired citizen
Joined
·
22,529 Posts
So mods ... can you put this OP's threads together ?
This thread belongs in the electrical section.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #9
Okay so I believe i have it down to 2 possible places, A , under the rear fender. B something to do with the hid head light, the headlight works off and on seems mostly at night it doesn’t work. I can mess with it pull my outter fairing unplug it and plug it back in and it usually works, it’s hit and miss. And the reason I think it could be the fender is it seen to rub everytime I hit a bump. And when I have my ol lady on the back it’s seems to rub at lot more, it’s not constant but you can definitely feel it under your butt. So maybe the wire harness ,
 

·
Registered
Joined
·
81 Posts
Start pulling fuses one at a time,begining with those you suspect. Then trace the colors. You do have a factory manual?
 

·
Barney Fife - Poser
Joined
·
893 Posts
Okay so I believe i have it down to 2 possible places, A , under the rear fender. B something to do with the hid head light, the headlight works off and on seems mostly at night it doesn’t work. I can mess with it pull my outter fairing unplug it and plug it back in and it usually works, it’s hit and miss. And the reason I think it could be the fender is it seen to rub everytime I hit a bump. And when I have my ol lady on the back it’s seems to rub at lot more, it’s not constant but you can definitely feel it under your butt. So maybe the wire harness ,
If your back tire is rubbing the fender, that isn't a "possibility", that is definitely a problem that you need to address immediately.
 

·
Retired citizen
Joined
·
22,529 Posts
Yep, probably got some rubbed wires inside the rear fender. OP needs to lay down next to his bike and look up under the fender with a flashlight and mirror. Or better yet jack the bike up for a closer look !
OP needs to stiffen up those rear shocks too IMO.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #14
I agree, it doesn’t do it unless I hit a bump or have riding double, I’ve looked up under the fender couldn’t see much I’ll put it on the lift and check it out for a farther inspection, i also ordered new shocks, new lights etc , I really do appreciate all the help and advice. It’s nice to have a community that helps and what’s to help instead of the normal hate and ugly b/s you see on some of these internet threads.
 

·
Barney Fife - Poser
Joined
·
893 Posts
Somebody obviously wanted to turn that thing into a Street Glide, judging by the SG fairing and lowered rear end.

I bought a 97 RK with a lowering kit on the rear and I will tell you that shitt is nothing but trouble if you actually plan on riding your bike. The first long trip I took it on with passenger and luggage got us about 200 miles before the rear fender harness was shredded and I had no turns, headlignt, brake light, speedo, and whatever else went. 3 hours sitting at a dealership in Newnan, GA put me a bit behind schedule for the day, but at least I got the lowering blocks out and a bunch of spliced wiring out of the deal.

I'd guess you got 3/4" or more worth of lowering blocks on that EG. Rip them out and ride it or park that baby in the garage and point at it and talk about how cool it looks while you enjoy beers with friends.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #18
Good to know, I’ll yank the blocks, I don’t give a dam about the lowering street glide look I need something practical I ride often and I ride distance, definitely makes sense with the headlight working off and on... thanks for the info!! I will have to pull the rear wheel to remove the fender correct?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #20
Okay so under the fender I found the bolt that holds my seat that had been rubbing, not anything to crazy under with the wiring I’ll post pics
 
1 - 20 of 31 Posts
Top