Harley Davidson Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter · #1 ·
Where to begin. I have a 05 Electra glide classic. Put alot of miles like 75000 miles. It started as a 88ci. The the inner cam bearing went out and shredded everything so had it rebuilt to 95ci. Well I decide to rebuild it like installed Andrew 31 cams. Ss lifters and adjustable pushrods. Had the heads shaved and ported. I installed 58 kuryakyn throttle body and k&n high intake cone intake. Around Sept it blew smoke out of exhaust and found out it bent a valve a cracked the guide also. So had a machine shop fix this. I put all new gaskets and new piston rings. I put it all back together. It starts fine and I'm in breaking in faze. It run fine as I think But not sure and I'm a little peranoid. Sounds like noise in the head and rocker box area. Sometimes a little tapping unless it's in my head. I made sure I did everything buy the book well if I read it right. Any one help me on this.
 

·
Retired citizen
Joined
·
24,285 Posts
Check the inside of the top rocker boxes, the rocker arms might be making contact. Look for contact smudges directly above the arms.
You can clearance the arms if needed with a Dremel grinder.
 

·
Registered
Joined
·
3,517 Posts
Depending on exactly what the noise sounds lie, and under what conditions you hear it. It could be a lifter needs adjustment, or a pre-ignition problem, and maybe needs higher octane fuel.
 

·
Wayward Son
Joined
·
23,864 Posts
Depending on exactly what the noise sounds lie, and under what conditions you hear it. It could be a lifter needs adjustment, or a pre-ignition problem, and maybe needs higher octane fuel.
I think I over did the pushrod. Because the timing was on and the lifters where ok. It also needs a good dyno tune if that has anything to do with it
If you over did a push rod then there is a good chance you either damaged a lifter and/or bent the push rod. You are lucky the piston(s) are ok.
Even a slight almost unnoticeable bend in the rod will cause problems.
 

·
Registered
Joined
·
57 Posts
Where to begin. I have a 05 Electra glide classic. Put alot of miles like 75000 miles. It started as a 88ci. The the inner cam bearing went out and shredded everything so had it rebuilt to 95ci. Well I decide to rebuild it like installed Andrew 31 cams. Ss lifters and adjustable pushrods. Had the heads shaved and ported. I installed 58 kuryakyn throttle body and k&n high intake cone intake. Around Sept it blew smoke out of exhaust and found out it bent a valve a cracked the guide also. So had a machine shop fix this. I put all new gaskets and new piston rings. I put it all back together. It starts fine and I'm in breaking in faze. It run fine as I think But not sure and I'm a little peranoid. Sounds like noise in the head and rocker box area. Sometimes a little tapping unless it's in my head. I made sure I did everything buy the book well if I read it right. Any one help me on this.
What are you using for oil?
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #9 ·
I think I over did the pushrod. Because the timing was on and the lifters where ok. It also needs a good dyno tune if that has anything to do with it
I did think of that. And closely checked that. And seamed ok.
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #11 ·
Thr straight 50 and see if the noise changes.
I was talking to a friend of mine. And he said his bike was making noise too and he used 60 weight and his motor got quieter so I have to try that out. Thanks. I let you know if anything changes
 

·
Wayward Son
Joined
·
23,864 Posts
Tread carefully if going to straight weight.

I got away with it in my Shovel. But that is 3 generations removed from the current engine.
Am pretty sure the MoCo was pretty adamant about using only multi-viscosity in the Evo`s. No idea about the TC`s.
Oil type is a lot more critical in cooler climates too.
 

·
Registered
Joined
·
57 Posts
Here I use 40w to break the engines in on the dyno and dump it after auto tuning and change to straight 50. I use Lucas non-synth on 95% of the builds I do with great success. Many of these are higher compression 107's and 117's.
 

·
Registered
Joined
·
12 Posts
I was talking to a friend of mine. And he said his bike was making noise too and he used 60 weight and his motor got quieter so I have to try that out. Thanks. I let you know if anything changes
if everything else all checks out good, replace your oil pressure spring.
 
1 - 17 of 17 Posts
Top