Harley Davidson Forums banner

1 - 20 of 57 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter #1
I changed out the bars on my 14 sgs today . Put everything together , now when I turn the switch on , only the head light , running lights and the fuel pump will come on . Nothing else works . Any idea what the problem could be ?


Sent from Motorcycle.com Free App
 

·
Learning Member
Joined
·
466 Posts
What 'Wire Management' did you have in place : Pics?, Diagrams?, Notes? Seems like you oughta check your process(es) . . . what can you reference?

I am very interested as I am going to be doing my bars over the next couple of weeks - would love to learn how this turns out! I have been planning pics with notes in soft copy format to reference.

Best of luck,
Rick.
 

·
On the loose
Joined
·
8,700 Posts
Did you move the ignition switch stalk at all once you pulled the switch cover off ?

Did you disconnect your battery before you dug into it ? You may have popped a fuse , that would be where I'd start , also disconnect it while your checking to let everything reboot.

Did you zip tie your TBW connector , modify the wires on it at all ? You may need to pull your fairing back apart and recheck all your connections.
 

·
Registered
Joined
·
154 Posts
Discussion Starter #5
Whatever I unplugged , I plugged back . Checked the fuses but all are good . I did pull the ignition out and had problems getting it back in . Seems to be in the right position .


Sent from Motorcycle.com Free App
 

·
On the loose
Joined
·
8,700 Posts
Does your radio or gauges light up ? If you move your ignition switch to different positions does it make a difference ?
 

·
On the loose
Joined
·
8,700 Posts
My dealer told me to be vary careful with the ignition switch , everything has to line up just right or it takes a special tool to realign it , not saying that's what the problem is just letting you know it's touchy.

Sure sounds like a missing connection some where .
 

·
The Angry One
Joined
·
10,578 Posts
Does any of your dash light up?? Idiot lights??
 

·
The Angry One
Joined
·
10,578 Posts
No , the only thing that's comes on is the headlight and the running lights .


Sent from Motorcycle.com Free App
My money is on the main switch then, if you are sure you re-connected all of the switch and light wiring. They have to be taken apart a certain way, and put back together a certain way.
 

·
The Angry One
Joined
·
10,578 Posts
U talking about the ignition switch ?


Sent from Motorcycle.com Free App
Yea. There is only one position you can remove it from, last I knew anyways, unless they changed something in 2014. And there is only one position to install it as well.
 

·
The Angry One
Joined
·
10,578 Posts

·
Registered
Joined
·
154 Posts
Discussion Starter #17
I did have a hard time getting it lined up at first but finally got it all the way down and seemed to be in the right position . It locked in the right spot so I figured that was it . Would the switch cause it not to come on ? When I turn it to ignition , u can hear the fuel pump kick on and the headlight and running lights come on , nothing else . None of the buttons work , the screen doesn't come on , horn doesn't work , etc .....


Sent from Motorcycle.com Free App
 

·
VA Fender Bender
Joined
·
5,551 Posts
I still suspect the switch
 
1 - 20 of 57 Posts
Top