Harley Davidson Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter · #1 ·
Hey Guys

I have a 2003 FLHTC with 90k KM. Bike has 95 kit,cams,Rineheart true duals, high flow air filter, and SERT. It was dino tuned a six years ago.
I have noticed that its running really rough when its cold. I didn't think too much of it because it went away when it warmed up. The past few days its been running rough when its warmed up. Tonight I pulled the plugs and they had a white dusty build up on them. This tells me the old girls running lean. My question is what might cause this to happen out of the blue.

On a side note I have been using the new shell high test gas and at the beginning of the season i ran some fuel treatment through it (4 tanks of gas have been ran through since)

Thanks for any help!!
 

·
Registered
Joined
·
13,193 Posts
Vacuum leak?
 

·
Banned
Joined
·
71 Posts
Intake seals are leaking. When they first start to leak, as the motor warms up, they will seal off . After some time they will no longer seal off as motor warms up.

Fits with what you have posted .
 

·
Indecisive Member
Joined
·
292 Posts
Intake seals are leaking. When they first start to leak, as the motor warms up, they will seal off . After some time they will no longer seal off as motor warms up.

Fits with what you have posted .
+1 for that

Spray some carb cleaner around all of your intake (just not into the intake) and if your rpm's rise then you have a leak. It is a fairly simple job to replace them as well.
 

·
Registered
Joined
·
85 Posts
Discussion Starter · #5 ·
Ill spray some throttle body cleaner around it and see if it affects the idle to test the intake leak theory. How would I be able to test for a vacuum leak?
 

·
Retired citizen
Joined
·
24,534 Posts
IAC might be dirty. Try squirting some carb cleaner into the IAC pintle hole and cycle the ignition several times to free things up.
 

·
Indecisive Member
Joined
·
292 Posts
Glad you got it running right.
 

·
Registered
Joined
·
13,193 Posts
Cleaned mine today, spayed & used a cleaning probe in there. All kinds of black stuff in there. Idle goes bad sometimes in hot weather, sounds like its running rich. Runs fine today.
 
1 - 13 of 13 Posts
Top