Harley Davidson Forums banner
1 - 20 of 31 Posts

·
Registered
Joined
·
169 Posts
Discussion Starter · #1 · (Edited)
Replaced a faulty voltage regulator today. Multimeter shows 13v during idle. Didn't seem to change with higher rpms though. Took her for a test ride and discovered something interesting. The blinkers work at idle but freeze at higher rpms. Any ideas what is wrong?
 

·
Banned
Joined
·
71 Posts

·
Registered
Joined
·
3,520 Posts
Check the stator output. And all connections in the charging system. Your charging voltage ( with a fully charged battery) should be 14+ volts. It should rise slightly when the engine is reved up.
 

·
Registered
Joined
·
169 Posts
Discussion Starter · #4 ·
Thanks for the quick replies. I'm about to run some more tests. This is my first time trying to diagnose electrical problems so please bear with my newbie questions:

1. When checking stator output, this should be while the bike is off, correct?
2. Are the TSSM code tests relevant to a 2001 Sporty?

My shop manual hasn't come in yet so for the time being, I have to turn to you all for things I might not otherwise need once that book gets here.

Thanks!
 

·
Banned
Joined
·
71 Posts
Thanks for the quick replies. I'm about to run some more tests. This is my first time trying to diagnose electrical problems so please bear with my newbie questions:

1. When checking stator output, this should be while the bike is off, correct?
2. Are the TSSM code tests relevant to a 2001 Sporty?

My shop manual hasn't come in yet so for the time being, I have to turn to you all for things I might not otherwise need once that book gets here.

Thanks!
Stator output is checked with motor running. Sticky in electrical section on how to do it .

If you have a security system..you have a TSSM..if you don't , then you have a TSM. Either way , the sticky will tell you how to pull codes and what they mean .

Two separate problems with two separate fixes . :thumbsup :)
 

·
Registered
Joined
·
169 Posts
Discussion Starter · #6 ·
I checked the cables, connections and the odometer codes and they were all clear. The only thing I didn't recognize was PPU and the number 72963 after the d01clr-d10clr codes. Or maybe I didn't do the test correctly. Does the computer simply recognize the problems upon entering diagnostic mode or do I need to run the bike and try the electronic components "while" in diagnostic mode?

I'll check the stator next, tomorrow sometime.

The voltage shortage when I tested it earlier could have been the not-fully charged battery (which did show 12 with the bike off).

But the greater oddity seems to me the fact that the blinkers flash properly when the key is turned on but the engine is off, yet if the engine is running they will turn on when engaged, stay on and not flash. I can turn them on and off (by engaging and disengaging the buttons) to create the "blinking" but they won't blink on their own. That is, unless the engine is off. Does this sound like a relay problem now?
 

·
Retired citizen
Joined
·
24,526 Posts
Sounds to me like you still have a charging system problem. 12 volts is almost totally discharged, should measure 12.8 volts fully charged with the ignition off.
The lights won't work properly if the battery is low. The ignition will be the last thing to quit working with the discharged battery.
Test the stator with the ignition off, check for opens and shorts as outlined in the electrical section sticky.
 

·
Registered
Joined
·
169 Posts
Discussion Starter · #8 ·
My voltage reading turned out to be a faulty meter. I took the bike to the local Harley dealer today for a courtesy check on the Voltage Regulator that I purchased and installed on Saturday and the readings were perfect, rising with the acceleration of the throttle. The battery is charged and reads right. Everything is great except for the turn signals now, which become more confusing each day. Today they started working properly after riding the bike for about 10 minutes, occasionally they would freeze. Once the bike was off, they wouldn't work correctly until the bike warmed up again and was on the road for a while. My service manual arrived today so I'll be able to check some more things properly and, once I replace my multimeter with a decent model, I'll try to troubleshoot the electrical problem and verify the stator (which had been checked and okayed a week ago by the local HD dealer here). In the meantime, thank you for the help and suggestions given.
 

·
Banned
Joined
·
71 Posts
My voltage reading turned out to be a faulty meter. I took the bike to the local Harley dealer today for a courtesy check on the Voltage Regulator that I purchased and installed on Saturday and the readings were perfect, rising with the acceleration of the throttle. The battery is charged and reads right. Everything is great except for the turn signals now, which become more confusing each day. Today they started working properly after riding the bike for about 10 minutes, occasionally they would freeze. Once the bike was off, they wouldn't work correctly until the bike warmed up again and was on the road for a while. My service manual arrived today so I'll be able to check some more things properly and, once I replace my multimeter with a decent model, I'll try to troubleshoot the electrical problem and verify the stator (which had been checked and okayed a week ago by the local HD dealer here). In the meantime, thank you for the help and suggestions given.
Sure sounds like you are getting a open intermittent circuit , hard to chase those down at times . Check all of the bulbs first . :)
 

·
Registered
Joined
·
169 Posts
Discussion Starter · #10 ·
Retracing one more step in the process of elimination, I had washed the bike on the same day I installed the Voltage Regulator, which was just hours before these problems began. I'm suspecting this has something to do with the electrical irregularities now.
 

·
Registered
Joined
·
13,193 Posts
Isnt there a relay/self canceling relay for the turn signals? Check all your relays are seated correctly, pull them check for moisture & in handle bar switch area. Could be ground some where. Just throwing cheap things to check out.
 
1 - 20 of 31 Posts
Top