Harley Davidson Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Recently I bought and install a SS510 Gear Cam Gear Drive in my 2000 Road King Classic, it has fuel injection. When its warm out or the bike warms up the Cam Gear starts backfiring and then the bike wont start. I am wondering what is recommended to correct that problem, and also is it possible to be a tooth off of top dead center.

I am mechanical inclined and replaced the part myself so just looking for advice to fix rather than taking it somewhere and paying 1000 dollars
 

·
Retired citizen
Joined
·
22,122 Posts
I would double check the pushrod adjustment.
You did install adjustable pushrods didn't you ???
 

·
Maddog
Joined
·
394 Posts
?!??

Cam gear backfiring? WTF, I've never heard of this, how does the cam
gear "backfire"

Backfiring where? Intake? exhaust?

I'd check the compression first
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
No I did not put adjustable push rods back in, and also I was told that I needed to buy a power commander, and reboot the computer to adjust the timing. But I dont know if a gear off would change the timing and still run.
 

·
Retired citizen
Joined
·
22,122 Posts
No I did not put adjustable push rods back in, and also I was told that I needed to buy a power commander, and reboot the computer to adjust the timing. But I dont know if a gear off would change the timing and still run.
I'm wondering about this ??? !!! Higher lift cams almost always require adjustable push rods.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
okay that might be the cheaper route to go anyways, do you know of any good places to pick up some adjustable pushrods?
 

·
Retired citizen
Joined
·
22,122 Posts
J&P's, Drag Specialties, Custom Chrome or the local H-D parts counter to name several.
 
1 - 7 of 7 Posts
Top