Harley Davidson Forums banner
1 - 20 of 20 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter · #1 ·
Got a 98 Low Rider, I recently put in new pushrods, tablets, and cam... took the bike on a nice ride today and noticed when I hit potholes or bumps, sounded like something was loose and rattling around in there... bike rides fine, shifts right and everything...what could wrong
 

·
Registered
Joined
·
42,546 Posts
Don't make sense. If it was valve train, it would be making that noise all the time.

Check out front suspension and neck bearings.
 

·
Kicking Rocks...
Joined
·
11,145 Posts
Did you have your exhaust off during surgery? If so, maybe loose heat shield.

Did you jack, maybe lost rubber bumper for jiffy stand.
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #5 ·
Nah, everything is tight... I didn't replace the inner cam bearing, was that a must??? The new cam fit right in it, so I figured I didn't need to replace, that, and I couldn't get it out...
 

·
Just Ride
Joined
·
3,843 Posts
Inner cam bearing won't make noise when you hit a bump. You got something loose. I think exhaust in hitting swingarm.
 

·
VA Fender Bender
Joined
·
5,551 Posts
Inner cam bearing won't make noise when you hit a bump. You got something loose. I think exhaust in hitting swingarm.
this
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #8 ·
I didn't think it was the cam bearing, I just checked my old cam and the new bearing I was supposed to replace & it fit the same way the new cam fit into the old bearing I couldn't get out... Just checked the front end & couldn't find anything loose, about to do a thorough look
 

·
VA Fender Bender
Joined
·
5,551 Posts
take a rubber mallet and pound around down there on the exhaust and clamp areas
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #10 ·
Just remembered, I installed an oil cooler that mounts on the engineering screws, but again, wasn't hard to put on an install it... I checked the oil cooler too and it's on tight...
 

·
Registered
Joined
·
2,379 Posts
Push rod tubes?
 

·
Retired citizen
Joined
·
24,344 Posts
Check the kickstand, is the rubber bumper in place so the stand doesn't bang against the frame ?
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #15 ·
Doesn't have a fork brace, it's not the kickstand, and push rod tubes are tight, I wear it sounds like its coming from inside where the cam is...
 

·
Retired citizen
Joined
·
24,344 Posts
Adjustable pushrods ? Might have not gotten one of the pushrods seated in the rockerarm socket and now that rod is loose. There should be about the same amount of threads showing on each rod.
Really should have replaced the inner cam bearing too, just saying.
 

·
Kicking Rocks...
Joined
·
11,145 Posts
Air cleaner cover or insert loose if you have that type....
And kickstand bumper is there?
 

·
Kicking Rocks...
Joined
·
11,145 Posts
Does the bike still have mid controls? Are all those items tight?
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #19 ·
Yeah, guys, everything is tight, I have like OCD, ADD and all that wrapped into one condition, I go over everything like 5-10 times to make sure everything is correct... I'm gonna take the cam cover off next to look inside
 

·
Registered
Joined
·
83 Posts
Discussion Starter · #20 ·
Went to my mechanic...1-need a new engine mount, that was the big clonking and knocking around.... And he thinks my pushrods weren't done correct.. I was dealing with new adjustable pushrods, I know I was at TDC, but don't remember if both rods were all the way down... Thanks for all the input & I will update later!!!
 
1 - 20 of 20 Posts
Top