Harley Davidson Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi, I have an issue i need help with. I just got my 99 electraglide classic out of winter storage, put in a brand new battery and fired her up. She ran for about ten minutes then just died. When i tired ti start it again it wouldnt start. After turning off the switch and turning it back on the bike fired right up again, ran for about 15 seconds or so then died again. It keeps repeating this proccess. Can someone give me some ideas as to what the issue might be. Thanks:biker::feedhttp://www.harley-davidsonforums.com/forums/images/smilies/feedback.gifback:
 

·
Registered
Joined
·
5,305 Posts
I'm guessing it has a carb. Check the vacuum line that goes from the tank petcock to the intake manifold. It may have a crack in it and not opening the petcock. OR, the petcock filter in the tank could be gummed up with debris, allowing only a trickle of gas to flow. Pull the drain plug on the bottom of the carb. and see what comes out.
 

·
Registered
Joined
·
72 Posts
Hi, I have an issue i need help with. I just got my 99 electraglide classic out of winter storage, put in a brand new battery and fired her up. She ran for about ten minutes then just died. When i tired ti start it again it wouldnt start. After turning off the switch and turning it back on the bike fired right up again, ran for about 15 seconds or so then died again. It keeps repeating this proccess. Can someone give me some ideas as to what the issue might be. Thanks:biker::feedhttp://www.harley-davidsonforums.com/forums/images/smilies/feedback.gifback:
See if it will run with the gas cap off...
 

·
Registered
Joined
·
5,305 Posts
Sorry Leonard; I can barely spell Magnetti Morelli fuel injection.
 

·
Retired citizen
Joined
·
24,282 Posts
That kind of sounds like an EMS sensor symptom. IAC, ETS, or CKP.
 

·
GO AVS
Joined
·
890 Posts
I'm guessing it has a carb. Check the vacuum line that goes from the tank petcock to the intake manifold. It may have a crack in it and not opening the petcock. OR, the petcock filter in the tank could be gummed up with debris, allowing only a trickle of gas to flow. Pull the drain plug on the bottom of the carb. and see what comes out.

My first thought, carb. Do you run fuel stabilizer? Before storing did you run the carb dry?

Edit just read it is fuel injected. Good luck with a marelli fuel injection. Hard to work on and very finicky, part of the reason Harley only used them for a few years

Sent from Motorcycle.com Free App
 
1 - 10 of 10 Posts
Top