Harley Davidson Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey everyone, needing some help on 05 Road King cruse. Problem green on/off comes on but cruse will not set. Every once in a while it will work. Harley told me it was the roll back cable replaced do not work. Thinking might have mositure on conections Sprayed some cleaner in it worked again for very short time. I am thinking the set/resume switch has gone bad. Has anyone had this problem. Thanks in advance for any help.
JIM
 

·
Hit it she goes boom
Joined
·
5,114 Posts
Try disconnecting your throttle position sensor. Two wires at the neck. Had the same issue on my 03. Been working ever since.. just didn't reconnect the wires.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Are you talking about the red and black wires below tank on right side. Harley said something about that tried it did not do anything. Im still thing the switch has gone bad
 

·
Hit it she goes boom
Joined
·
5,114 Posts
Are you talking about the red and black wires below tank on right side. Harley said something about that tried it did not do anything. Im still thing the switch has gone bad
Mine are both black, but its a disk shaped sensor thats on the cable. My cruise was "choppy" then sometimes didn't work, then stopped working period. This was the problem on my bike.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
cruse control

Hey everyone, needing some help on 05 Road King cruse. Problem green on/off comes on but cruse will not set. Every once in a while it will work. Harley told me it was the roll back cable replaced do not work. Thinking might have mositure on conections Sprayed some cleaner in it worked again for very short time. I am thinking the set/resume switch has gone bad. Has anyone had this problem. Thanks in advance for any help.
JIM
 

·
Retired citizen
Joined
·
23,201 Posts
Run the diagnostics to pull up stored codes. The procedure is a sticky in the electrical section.
 

·
Retired citizen
Joined
·
23,201 Posts
Also the front or rear brake light switch could be the problem. Do your brake lights stay on ??? Were the grips changed ?
 

·
Hit it she goes boom
Joined
·
5,114 Posts
Almost forgot.. keep in mind your brakes cancel your cruise, try jiggling one at a time to see if you get any response, it doesn't take much to cancel, I've had my foot slide down on the highway peg and feel that cruise become jerky, only to find my heel is touching the rear brake pedal, not enough to cancel, but enough to change it.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
Thanks guys I will check thoes things this week and let you know how it goes before I replace the switch.
Thanks again,
Jim
 

·
Just Riding Around!
Joined
·
122 Posts
Had a friend that had problems with his cruise control cutting off or not coming on at all. Turned out all he needed to do was clean the contacts on the electrical connections and apply a little dielectric grease to all connections. The grease ensures a positive contact and uninterrupted flow of current. Also keeps out the moisture that can corrode the contacts.

You may want to give that a try as well.
 
1 - 10 of 10 Posts
Top