Harley Davidson Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
13,191 Posts
Could be short or bad ground wire. Do the brake lights work properly or do they come on with cruise light. Stranger things have happened ???
 

·
Registered
Joined
·
5,441 Posts
If your '05 is same as my '07, there is a "roll off" switch located in one of the throttle cables, just in front of the front gas tank bolt. I't's a two prong connector. Even without cruise, one of the wires is hot, and may be shorting against something. If it's not that, start looking at all of your cruise control wiring (I hope you have a serv. manual) for shorts.
Here's a pic of the connector.
 

Attachments

·
Banned
Joined
·
71 Posts
If there's an intermittent short how do I go about finding it since it only does it randomly
That's why it's a biautch to find . :mad

Start by looking at each connection in the circuit, see if it's clean ,tight and without any arc marks .

Look at your bulb connections too, at times they will short to the housing .

Run the wiring, looking for worn insulation , look carefully anywhere it turns a corner or goes over a bracket .

Good Luck to you . :)
 

·
Indecisive Member
Joined
·
292 Posts
Another thing to help find it is pull everything that covers the wiring harness for that circuit and visually as well as feel each individual wire for cracks, abrasions, and abnormal alities. Shake the wires and watch for the light to pop back on. That should help you out as well as verified all the connections are solid.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top