Harley Davidson Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Just bought a 2012 Ultra Classic 103" . Starting at 2400 rpm & up
there is a distinct increase in engine vibration, you can feel it in the
handle bars, footboards, even the seat. My '07 Road Glide w/ 96"
engine has nothing like that. Bike has 10,000 miles, previous owner
is deceased so I can't ask any questions there. It was well taken care of though and I don't think abused. I am going to a dealer this
week, but I expect they will tell me it's normal. I have had several
Harleys (11) and it doesn't feel normal to me. My question is this --
Do the 103" motor's vibrate more?
 

·
Registered
Joined
·
5,301 Posts
Also check that nothing on the exhaust system is touching the frame except the mounting tabs.
 

·
Registered
Joined
·
5 Posts
If you could.let me know how you make out.I have a 2015 street bob with the 103 and two seperate dealers and 4 techs have told me this was normal for a dyna.I find it hard to believe anyone would buy these if this was normal in the ideal cruising rpm range 2400-2700
 

·
Glad to be anywhere
Joined
·
4,335 Posts
I've got a 2012 with the 103 and I get a vibration at 20 mph going up or down and only between 17 & 20; in or out of gear; revving or idling.

Thought it was belt, but no. I noticed it after my 5,000 service. They said it wasn't the brake.

I'm begining to think it's the windshield. Tires are OK.

Any one else seen this??????
 

·
Registered
Joined
·
163 Posts
I recently had my bike worked on and after I got it back there was a terrible vibration sometimes.

Finally tracked it down to the exhaust was making contact with the brake lever pivot pin, the one with the cotter pin in it.
 

·
Call me Gig.
Joined
·
3,964 Posts
Just bought a 2012 Ultra Classic 103" . Starting at 2400 rpm & up
there is a distinct increase in engine vibration, you can feel it in the
handle bars, footboards, even the seat. My '07 Road Glide w/ 96"
engine has nothing like that. Bike has 10,000 miles, previous owner
is deceased so I can't ask any questions there. It was well taken care of though and I don't think abused. I am going to a dealer this
week, but I expect they will tell me it's normal. I have had several
Harleys (11) and it doesn't feel normal to me. My question is this --
Do the 103" motor's vibrate more?
I told a guy in the Dyna forum this. If the dealer says it is normal then find another 2012 Ultra Classic that you know they have and make him prove to you that it is normal.
 

·
Registered
Joined
·
36 Posts
Describe it - high pitch buzzing vibration? or heavy pulsing like a stuck compensator? or just an uneven out of balance vibration? or ?

Have you tried riding another Ultra? Even if it's not the 103 - I was really surprised that the unbalanced motors "feel" so different than the balanced ones...

just take something for a test drive...
 

·
Registered
Joined
·
12,940 Posts
I've got a 2012 with the 103 and I get a vibration at 20 mph going up or down and only between 17 & 20; in or out of gear; revving or idling.

Thought it was belt, but no. I noticed it after my 5,000 service. They said it wasn't the brake.

I'm begining to think it's the windshield. Tires are OK.

Any one else seen this??????
You have the B motor should be smooth. Don't get buzz out of mine till almost 4k, then again its a 96 motor. Check your top motor mount bolts going into the heads, one each. My rear cyl. one would loosen up, feel it on the road. After repeated tightening. Removed all 3 bolts, cleaned and torqued every thing. Blue Loctite on head bolts, just a touch of red on frame mount bolt.
 

·
Glad to be anywhere
Joined
·
4,335 Posts
You have the B motor should be smooth. Don't get buzz out of mine till almost 4k, then again its a 96 motor. Check your top motor mount bolts going into the heads, one each. My rear cyl. one would loosen up, feel it on the road. After repeated tightening. Removed all 3 bolts, cleaned and torqued every thing. Blue Loctite on head bolts, just a touch of red on frame mount bolt.

Thanks for responding
 

·
Registered
Joined
·
170 Posts
For what's it's worth, I recently installed new tires and after both front and rear tires weights fell off I experienced substantial vibration in the floorboards and gas tank. I reinstalled the Dyna Beads that I asked the tire installer/balancer to save from the old tires. That did the trick for me......smooth as glass when on perfectly smooth roads. So, in my case it was tire balance. Your problem may be something entirely different.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #12 ·
Frt motor mount is tight, bike has true duals and left side was touching pass. ft board. Took care of that and vibe. is better but still there. I ordered a Hayden primary chain tensioner. I will post results when I get it installed. Thanks to all who replied!
 

·
Registered
Joined
·
2 Posts
I had the same problem with my '16 FLTRU. I had a '13 FLTRU and it was smooth as silk. The '16 vibrated my fillings out. I balanced the front tire, that helped a little. Then I took it in and said "re-torque everything that touches the motor. That made a huge difference, although it still vibrates more than my '13 103 did.
 

·
Registered
Joined
·
22 Posts
I've got a 2012 with the 103 and I get a vibration at 20 mph going up or down and only between 17 & 20; in or out of gear; revving or idling.

Thought it was belt, but no. I noticed it after my 5,000 service. They said it wasn't the brake.

I'm begining to think it's the windshield. Tires are OK.

Any one else seen this??????
Did you fix vibration. I have a 103 softtail doing the same thing
 

·
Registered
Joined
·
46 Posts
Check the fluid levels. Crankcase and transmission. I find with my bike the levels need to be spot on, if a touch too much it acts weird.
 

·
Registered
Joined
·
22 Posts
Did you fix vibration. I have a 103 softtail doing the same thing
No still vibrating. Replaced the compensator and the starter clutch. Which were both stuffed any way. Made a slight difference but still vibrating when under load. Alright when cruising. Using excessive fuel and lost some power.
 
1 - 17 of 17 Posts
Top