Harley Davidson Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My husband is working on a 2005 Electra Glide for a friend. He had a non working gas gauge. After replacing the gauge and the fuel sensing module it works. When he went to return the motorcycle he saw the turn signals and brake light no longer work. Our friend insists they were just fine when he dropped off the bike. The running lights work and all the gauges work. He believes he needs to replace the turn signal module located next to the battery. The part is over $250 and our friend feels we must have broken something in installing the fuel sensor.
Could this be the case? Are these things all related or just crazy coincidence?:feedback::feedback:
 

·
Indecisive Member
Joined
·
292 Posts
Pull the tank and seat back off as well as the fairing and check all your work. You may have left something disconnected or pinched a wire. Do all the other switches on the handle bars work correctly?
 

·
Banned
Joined
·
71 Posts
My husband is working on a 2005 Electra Glide for a friend. He had a non working gas gauge. After replacing the gauge and the fuel sensing module it works. When he went to return the motorcycle he saw the turn signals and brake light no longer work. Our friend insists they were just fine when he dropped off the bike. The running lights work and all the gauges work. He believes he needs to replace the turn signal module located next to the battery. The part is over $250 and our friend feels we must have broken something in installing the fuel sensor.
Could this be the case? Are these things all related or just crazy coincidence?:feedback::feedback:
Don't just toss parts/money at the problem.

Start at the beginning , check fuses and bulbs first . Check to make sure all connections are fully plugged together .

Pull DTC codes . Sticky here tells you how and also how to read them . http://www.harley-davidsonforums.co...-big-twin-carb-efi-dtc-intructions-codes.html


Pull TSSM codes . http://www.harley-davidsonforums.com/forums/electrical/16369-tsm-tssm-trouble-codes.html
 
1 - 6 of 6 Posts
Top